Replicator Composer with transparent objects

Hi, I am trying to use replicator composer with semi transparent objects e.g. the objects include some parts made of glass.

It works great for non transparent objects but the glass is not visible in the generated images. In Isaac Sim I need to enable “Enable Fractional Cutout Opacity” under Render Settings → Ray Tracing so see the objects. How do I do that in replicator composer?
Here is the original post where I got the solution for Isaac Sim: Opacity adjustment not working - #6 by samuel.blanchet.2

1 Like

okay I found a workaround by manually setting:

CUTOUT_OPACITY = “/rtx/raytracing/fractionalCutoutOpacity”
carb.settings.get_settings().set(CUTOUT_OPACITY, True)

inside […].local/share/ov/pkg/isaac_sim-2022.2.1/tools/composer/src/main.py

If someone knows a better way, I am looking forward to it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.