Restore JETSON Orin NX failed with JetPack5.1_R35.2.1

  • JetPack5.1_R35.2.1 with JETSON Orin NX som in our customed bouard.

  • We backup Orin NX system by sudo ./tools/backup_restore/l4t_backup_restore.sh -b p3509-a02+p3767-0000, and restore sudo ./tools/backup_restore/l4t_backup_restore.sh -b p3509-a02+p3767-0000

  • We have purchased three SOM, the first for use as a backup system, and the remaining two can be restored normally . The following figure is part of the program.

  • Later, I bought 10 more SOM, but none of them could be successfully restored. The following figure is a screenshot of a restore failure.


    flash failed log (6.6 KB)

  • As show in picture, the board model that doesnot match ?

  • So, this is caused by different SOM?

Yes, please check if your “10 more SOM” is really Orin NX 16GB or something new…

both of them are Jetson Orin NX (P3767-0000 with 16GB), lsusb can ensure that. lsusb result is : 7323 in recovery mode.

Hi,

Please flash single device first, boot up and share cat /etc/nv_boot_control.conf.

Also, share the same result from the device where you got clone out.

1 Like

This is the first we buy three SOM: nv_boot_control.conf_3SOM (270 Bytes)
This is the second we buy 10 SOM: nv_boot_control.conf_10SOM (270 Bytes)

please try to comment out the check in below of this script and see if it can bypass
Linux_for_Tegra/tools/backup_restore/nvrestore_partitions.sh

283 done
284 if [ ${BOARD_MATCH} = false ]; then
285         echo "${SCRIPT_NAME}: You are trying to flash images from a board model that does not"
286         echo "match the current board you're flashing onto."
287         exit 1
288 fi

1 Like

Thank you very much , it worked.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.