Flashing my Jetson Orin NX using SDK Manager failed

I am trying to flash my Nvidia Jetson Orin NX 16GB with JetPack 6.0, but it fails. The device was already pre-flashed with Jetpack 5.1.1 and I followed the steps described in this article.

Everthing works up until the actual installation, it fails with this error:

15:24:42 ERROR: Can not find matching device in recovery mode.
15:24:42 ERROR: Flash Jetson Linux - flash: --- Error: Reading board information failed.
15:24:42 ERROR: Flash Jetson Linux - flash: *** ERROR: Parsing boardid failed
15:24:42 ERROR: Flash Jetson Linux - flash: [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_JETSON_LINUX_COMP.lab.sh; [error]: *** ERROR: Parsing boardid failed

The full error log is attached. I tried using different USB 3.1 cables and different ports of the host PC, which is running Ubuntu 22.04. Attached is the “Flash” dialogue.

error.txt (2.5 KB)

Only saw a picture. Didn’t see anything else attached.

My post got hidden during editing, now the error log is attached

1 Like

Also I checked for the device being in recovery mode using lsusb, this is the result which looks fine I think:

Bus 001 Device 015: ID 0955:7323 NVIDIA Corp. APX

Did you ever flash this board with this host before?

I mean something like jetpack5.

No, the board came pre-flashed

Try other host PC. Most likely the issue on pc that cannot detect the board correclty.

I tried a different PC, which resulted in the same error. I also tried another Jetson Orin on both PC’s, which failed on both with the same error.

Could you share your method to put the board into recovery mode?

Hello, @simon.michel could you solve it? I am having the same problem with my Jetson Orin Nano 8GB dev kit.