Robot not work properly | Isaac Cortex | No Error Message

I am trying to use
Isaac Cortex(11.1. Isaac Cortex: Overview — Omniverse IsaacSim latest documentation) to do Path Planning for my robot, but my robot work like that( not normal), Is anybody know the problem might be? there is no error message, just cannot work properly.


Are you basing your simulation in the UR10 bin stacking one? Have you configured approach_length and direction?

Yes, I am based on the UR10 Bin Stacking Task Example! Regarding the configured approach_length and direction parameters, I haven’t made any modifications; they are the same as in the UR10 example.

approach_length = 0.3
direction=approach_length * ax

If there is a need to make modifications based on my robot, is there any documentation available?
Thanks for your help!!

I believe you should modify those for your task, depending on the pose of the object you want to grasp and also because of the borders of your box. Have you tried without the box? Also, the posture_config helps to give a desired robot general form.

The last section of this has some information about those axes :

Thank you. However, even though I read the tutorial you posted, I have still no idea how to set the parameter properly.

I’m just another user, so take everything I say with a grain of salt. I’m working in a somewhat similar problem. Based on your video, I think your approach_length = 0.3 should be fine. You should set the posture with joint values that corresponds to a “good arm posture” like your initial posture when the arm is right above the box. Your biggest problem I think is choosing the right direction for grabbing each item. Experiment setting:

direction=approach_length * ay
direction=approach_length * az

Just so you better understand those. Also, you will probably have to come up with a heuristic to choose the item you grab (maybe the easier items first, maybe the ones more centralized in the box?)

Have you tried with a single item? Does it work?