Rootfs does not support NFS export (ReOpen Never Solved)

Unfortunately, I am also having the same issue as the issue from the Post labeled the same as above. What makes matters worse as is that it just auto closes after so many days, but unlike github, I cannot just reopen it.
Regardless of the extra headaches, I will just take it from where we were in that post.

Here is a screenshot of the last post.

And here is my answer:

FileSystem Type Size Used Avail Use% Mounted-On
/cow overlay 118G 60G 53G 54% /


Usually this comes down to whether the driver exists in the kernel. In some cases there is external user space software which must also be used. As an example, ext4 mostly just needs “mount” and the ext4 kernel driver, whereas NFS will need “mount”, its own kernel driver, and extra user space software. NFS further complicates this because there is NFS v3 and v4 to deal with.

I have not really experimented with overlay, but it does need the kernel driver which is separate from the underlying filesystem (which also needs its driver; I don’t think all underlying filesystem types work with overlay, so you would need to know that the underlying filesystem works with overlay).

What filesystem exists under the “/cow” directory? I assume you are using this subdirectory for something like a kiosk. It should probably be ext4. I don’t know, but to get things started, post the following (someone else will be able to use this):

  • zcat /proc/config.gz | grep -i overlay
  • zcat /proc/config.gz | grep -i nfs
  • Content of “/etc/fstab”.
  • Full output of “lsblk -f” and “df -H -T”.
  • Is this set up to run on boot? If so, the full serial console boot log.
  • Is this something you can attempt to mount manually? If so, then run “dmesg --follow”, and during the manual mount attempt, post whatever log lines or command output are created from the attempt to mount.

Mostly I’ve worked on building kernel source, but I don’t actually have anything I’ve tested on. Note that overlayfs has multiple options, and that some are not used for some situations, but might be needed for other situations.

I am going to mention that exporting NFS also has its own limitations. It is quite possible that does not support this. Or it is possible that NFS v3 does not support this, but perhaps NFS v4 does. Attempting a manual mount quite often results in a useful kernel log message when something fails. Related to all of this, can you say whether the overlay is working when used locally without NFS? If overlayfs works, then mainly it is a question of what logs show up when mounting as NFS.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.