ROS2_bridge communication problem

Dear all,

I have a problem communicating between the ROS2_bridge in isaac sim and custom ROS2 nodes running in a Docker container on the same machine.
This problem exist in isaac sim 2022.1.1, as well as version 2022.2.0. The Docker container running ROS2 is taken from the isaac_ros_common repository on github.
When running for example the standalone example of isaac sim 2022.2.0, the robot moves as expected. However, in the docker container a > ros2 topic list command doesn’t show any topics.
This problem is probably related to FastRTPS, but I already tried various FastRTPS profiles, all without success.

Does anyone else observe such a behavior and can me help?

I would also be very interested in a solution since I have exactly the same problem.

Hi @mardybum - Have you tried installing the latest version of Isaac Sim 2022.2.1?

Let us know if you still see the issue in that version.

Hi @lukas.hindemith1 and @mardybum , when you do a ros2 topic list do you get something like Failed init port fastrtps... ? Also, it is not clear if you’re able to control the robot/interact with it via ROS2. The FastRTPS fix must be done prior to starting the simulation application (should be done in same terminal as well to set env variables correctly)