Cannot listen ros2 topic on same machine

I am testing the ros2 interworking function in isaac sim,

After running ros example on the machine where isaac sim is installed, I open a new terminal and run ros2 topic list, but I do not receive a topic.

However, other machines connected to the local network receive the topic.

I got the error

[RTPS_TRANSPORT_SHM ERROR] Failed init_port fastrtp_port7416: open_and_lock_file failed ā†’ funaction open_port_internal

Is this the reason of this error?

Who has the same problem as me? I wonder if there is any solution.

1 Like

Iā€™m having the same error. It does work with ROS1 though.
For more context:
on AWS EC2 instance,

  • installed Isaac Sim and ROS2 Foxy and Moveit2 Foxy
  • Opened up Isaac Sim - MoveIt Tutorials, hit play,
  • Opened up a terminal, sourced ros2 setup.bash, and entered ros2 topic list. It did not show any of the topics.
    Thought this was an EC2 instance problem, tested this on my local machine, same error.
    Installed ROS1, and tested this with ROS1, and it worked. I was able to see all the topics by doing rostopic list.

I tried doing ROS_LOCAHOST_ONLY=1, but still same errors

Hi, I followed this solution of link and solved the problem.

export FASTRTPS_DEFAULT_PROFILES_FILE=~/.ros/fastdds.xml
export RMW_IMPLEMENTATION=rmw_fastrtps_cpp

fastdds.xml file is located in isaac_ros_common/rtps_udp_profile.xml at main Ā· NVIDIA-ISAAC-ROS/isaac_ros_common Ā· GitHub

Hope to solve the problem.

Hey Jwson3, thanks a lot for the reply. That kinda worked. I had to turn off my WiFi though. Do you happen to know any solution that would still allow me to connect to Internet and have this work?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.