Cannot access isaac_sim's ros_topic from another computer

Hi everyone,
I ran Simulation on Isaac Sim 2022.1.1 and published several ROS topics (/rgb, /odom, /scan, …) through ROS_Bridge Extension. I can access all these topics on my host computer (the computer was running omniverse isaac sim) and showed them on Rviz. But when i tried to access them from another computer, there was no messages from the topics.
Can i access isaac_sim’s ros topics from another computer? If yes, how do i do to get messages from the topics?

Were the topics visible but no messages received? or the topics were not visible either?

the topics is visible when commanded like ‘rostopic list’, but when i tried to accessed ‘rostopic hz /topic_name’ there were no messages

1 Like

And could you publish a topic manually outside of sim and receive it on the other computer?

yes, as i said above, i run simulation on isaac sim and received messenges from topic on My Host Computer but when there were no messenges when i tried to access from another. Note that all the other topics (from outside of Isaac Sim) worked normally from host to clients.

Understood, trying to make sure we’re trying to reproduce on our end correctly.

Is roscore/rosmaster running on the sim side or the client side?

i ran roscore on host computer, which i ran Isaac Sim