Run sample_camera_multiple_gmsl failed on PX2

Hi,

I’m trying to run Drivework sample on PX2, but I’ve got an error.

Execute ./sample_camera_multiple_gmsl --selector-mask=1001

error message,
Program Arguments:
–cross-csi-sync=0
–fifo-size=3
–offscreen=0
–selector-mask=1001
–slave=0
–type-ab=ar0231-rccb
–type-cd=ar0231-rccb
–type-ef=ar0231-rccb

Initialize DriveWorks SDK v0.3.422
Release build with GNU 4.9.2 from v0.3.1-rc2-0-g0475f26 against PDK v4.1.6.3
SDK: Resources mounted from /usr/local/driveworks-0.3/data/resources
SDK: Create NvMediaDevice
SDK: use EGL display as provided
SDK: dGPU has been detected as device number 0
SDK: iGPU has been detected as device number 1
SDK: Default GPU Device set to device number 0
SAL: identified board as DrivePX2-TegraB
SensorFactory::createSensor() -> camera.gmsl, csi-port=ab,camera-type=ar0231-rccb,camera-count=4,camera-mask=1001,slave=0,cross-csi-sync=0,fifo-size=3
CameraGMSL: required FPS = 30, resolution = 1920x1208
receive_from: Timeout Error.
Please check Ethernet ip configuration or
check Aurix firmware version
iscRootDevOpen: Failed to power on camera(s)
NvMediaISCRootDeviceCreate: Unable to open root device
nvmedia: ERROR: Init: Failed to create NvMedia ISC root device
Driveworks exception thrown: DW_SAL_CANNOT_CREATE_SENSOR: CameraGMSL: cannot connect to camera
Cannot create driver: camera.gmsl with params: csi-port=ab,camera-type=ar0231-rccb,camera-count=4,camera-mask=1001,slave=0,cross-csi-sync=0,fifo-size=3
Error: DW_SAL_CANNOT_CREATE_SENSOR
Need to specify at least 1 at most 12 cameras to be used

And I’ve following the below link try to get Aurix version,
https://devtalk.nvidia.com/default/topic/1011227/drive-hardware/running-sample-gmsl-camera-app/

But I got these message,
starting Aurix FW checking…
Checking arguments…
Aurix OTA is only valid for DrivePX2 Tegra A and ACR

Does anyone have any idea?

Thanks!
Vincent CH Wu.

Dear Vincent_CH_Wu,
Please check Recording from Three camera sensors()page 74) in NvidiaDriveworks_DevGuide.pdf.
Please provide correct mask value according to the camera position.

Hope this helps

Hi SivaRamaKrishna,

I’m select port 0 and 3 camera from ab port, and I use 1001 as my selector-mask,
I execute with these parameter.
“./sample_camera_multiple_gmsl --selector-mask=1001”

Do you have any idea?

Thanks!

Dear Vincent_CH_Wu,

Could you please check Aurix FW version via Host PC with $sudo minicom -D /dev/ttyUSB1?
If PDK version is 4.1.8.0(Beta3.0), Aurix FW version should be 2.02.04. Thanks.

Dear Vincent_CH_Wu,
Could you check if you are able to run sample_camera_gsml. If not. please update the Aurix version from windows host using instructions provided in the section Flashing and Using the Platform -> Flashing AURIX in https://docs.nvidia.com/drive/nvvib_docs/index.html.

Hope this helps

Hi,

After check Aurix FW version and update Aurix FW, this problem is resolved, thanks for you guys help!