RuntimeError: Failed to acquire interface: carb::gym::Gym (pluginName: nullptr)

Hi,

I’m facing a bug where when I try to run an example script joint_monkey.py on issac gym via miniconda in ubuntu 20.04, I get

Importing module ‘gym_37’ (/mnt/c/Users/username/Documents/isaacgym/python/isaacgym/_bindings/linux-x86_64/gym_37.so)
[Error] [carb] [Plugin: libcarb.gym.plugin.so] Could not load the dynamic library from /mnt/c/Users/username/Documents/isaacgym/python/isaacgym/_bindings/linux-x86_64/libcarb.gym.plugin.so. Error: libmem_filesys.so: cannot open shared object file: No such file or directory
[Warning] [carb] Potential plugin preload failed: /mnt/c/Users/username/Documents/isaacgym/python/isaacgym/_bindings/linux-x86_64/libcarb.gym.plugin.so
Setting GYM_USD_PLUG_INFO_PATH to /mnt/c/Users/username/Documents/isaacgym/python/isaacgym/_bindings/linux-x86_64/usd/plugInfo.json
[Error] [carb] Failed to acquire interface: [carb::gym::Gym v0.1], by client: carb.gym.python.gym_37 (plugin name: (null))
Traceback (most recent call last):
File “joint_monkey.py”, line 59, in
gym = gymapi.acquire_gym()
RuntimeError: Failed to acquire interface: carb::gym::Gym (pluginName: nullptr)

I followed the installation steps provided in the IsaacGym setup and have tried reinstalling my Nvidia drivers but also get this message when running nvidia-smi: NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

What else can I possibly do to run IsaacGym? Let me know if I need to provide any versions of programs I’m running for debugging purposes.

Hi @simtester101,

Are you testing on WSL (Windows Subsystem for Linux)? Your /mnt/c/Users pathnames suggest you are. If so, I’m afraid that we haven’t tested much on that.

Also note that you should be doing the pip installation with the ‘-e’ option, per the documentation. Others have reported some issues without it (`libmem_filesys.so: cannot open shared object file` · Issue #62 · NVIDIA-Omniverse/IsaacGymEnvs · GitHub)

Good luck,
-Gav

Hi @gstate

Thanks for your comment. Which system would you recommend testing it on? I have a Windows laptop and it didn’t work locally so I tried on Ubuntu again.

Thanks

I would recommend a system that meets the minimum specifications we show in the download area

  • Ubuntu 18.04, or 20.04.
  • Python 3.6, 3.7, or 3.8
  • Minimum recommended NVIDIA driver version: 470.74 (470 or above required)
  • Minimum required hardware: NVIDIA Pascal or later GPU with at least 8gb of VRAM

Are you running on a native Ubuntu 18.04 or Ubuntu 20.04 OS on a machine with an NVIDIA GPU? Did you use the -e option when doing the pip install?

Take care,
-Gav

Hi @gstate,

Thank you for the recomendation. I am now using Ubuntu 20.04 with python 3.7 and NVIDIA driver higher than 470 but am still facing the same error . I ran the pip install with the -e option as pip install -e .

I am running Ubuntu 20.04 through a dual boot on an external hard drive through my Windows laptop and install all the necessary drivers using the cuda toolkit. Is there a certain version I need or anything else I should try to resolve this issue?

Thanks