Screen blinks periodically when opening some apps or sub-menus -- Ubuntu 20.04, GeForce GTX 1050 Ti

nvidia-bug-report.log.gz (779.3 KB)

The screen blinks off then on again periodically, usually when opening a dialog box in a program. It may blink only once but often many times in a row and sometimes never returning. Hitting the enter key which closes an open dialog often gives me the screen back.

It only seems to happen in a stand-alone application, never during a browser session.

There’s not much more I can say other than I have seen this issue before and a google search will give many fixes but none of them have worked for me.

Not much to see in the logs besides a possible problem with your webcam. Please try to unplug it and check if that’s the source.

I’ve actually had had two webcams hooked up at the same time. I’ve disconnected both and the problem still persists, which is what if figured.
There is either a video configuration issue or the proprietary drive has a bug.


Did you try using a different DP-cable?

No, but I did use an HDMI cable and it had the same problem.

This problem is all over the internet, most people have never found a solution.

So not all of the above are the same hardware, but all are Nvidia and all seem to have very similar issues. I stopped at three links but there were many more.

This problem will never be solved by recommending a cord change. I’m a professional and know better than to not check something like that.

Please do a bit more research into this as it is a real issue that has plagued Nvidia cards and Linux for many years.


I guess the examples you gave have nothing to do with your issue. Two only occur while playing full-screen games, likely using proton, one is due to a VT switch.
One detail you left out is you’re running Kubuntu. Kwin’s compositor is known to not playing nice with the proprietary nvidia driver and also has general issues, like:
one of which pretty much sounds like yours, modal dialogs make screen blink.
Please check if this is the root cause by disabling compositing in kwin.

Actually, they describe two issues in your post, the second to the last post was right on the money with my issue, the rest of the posts have nothing to do with my issue.
The three links I posted were also right on the money except they all mention different situations that caused their issues. What a person does most is what a person will post as the trigger to the issue.
I did however disable compositing, but it didn’t solve the issue. What helped was changing the Rendering backend to OpenGL 3.1 instead of the default OpenGL 2.0. This has minimized the blinking on and off but it still happens.

So the upshot is the compositor is not the real issue since the blinking happens with it turned off. I’m still placing my money on the driver.