Very short black flickering (flashes) with nvidia 2080Ti since nvidia 530.41.03 driver

Hello,
I updated today Manjaro and that includes the nvidia driver (530.41.03). I have a Dell TFT with 1440p@144Hz
connected with Display Port. Im also using X11 and not Wayland.

Im experience short black flickering (flashes), even open kate (text editor) or starting terminal, it shows a strange behavior at random times.

After installing nvidia-settings (i have a 2080Ti) and after a restart i got it reduced a little (xserver was removed from nvidia-utils btw. so i had to reinstall it).

But i still see it flickers/flashes again when i open Steam or right now in Firefox, while i write this message.

I also openend a bug Topic in Manjaro Forum today, but with no success :(

Please help me out… you can find some additional infos about my system and stuff like that in the Manjaro Forum:

This is probably a less than stellar thing to test with you running KDE but try disabling the compositor (KWin). I’ve been running a while without my compositor and the flickering seems to be gone. I’ll be interested if this fixes things for you too. Then at least we’ll have an idea as to what the driver is causing issues with.

I unchecked the compositor (enabled on startup = off) and i think its reduced alot, but i saw it flashing again 2 time in the last 10min, im not sure if its a placebo but it looks less frequently now… but still there.

Maybe a restart is required for fully disable after i deactivate the check box… im not deactivated the service Kwin yet or should i try that next?

It has nothing to do with kwin. It is a driver bug. Watch what happens when the power state changes on your GPU. It will flicker.

1 Like

Like dvsaleios said, it has nothing to do with compositor… i tested it out and i could see it flickering with compositor disabled, it may reduce a little because the powerstates not switching and jumping around as with compositor enabled but no real difference.

Do you know a work around? Maybe we can force the Powerstates somehow? If thats the only reason why it flickers.

I have not much hope, that nvidia will fix this driver bug anytime soon.

My last nvidia driver bug (dithering bug) on Linux took 1month till nvidia confirmed there is a bug going
and it takes another 3 month till it was fixed.

I swapped PowerMizer to ‘Prefer Maximum Performance’ in nvidia-settings. That mitigated it. Still happens but with a lot less frequency. I don’t know how the curve looks with that profile but it will sometimes go down to 2 from 4 every now and then.

Yeah, I’m hoping an NVIDIA engineer can clarify the proper issue at some point.

Changing power states does not trigger it for me. There is no doubt it’s a driver bug, I never said the bug was the compositors but merely the flickering was the driver bug tripping up the compositor. If we can be free of the obnoxious flicker by shutting down the compositor for a few days until this is fixed then it’s a better alternative.

I am running sans compositor and I have not seen the flicker. That said the driver bug is probably affecting various draw calls my machine doesn’t do but yours does due to running KDE. All the KDE effects and features will no doubt use various calls and transforms on the GPU that will trigger the problem far more than my WM.

1 Like

Yeah you right, i also looked at my Powerstates in xserver and then Powerstates not triggering the flicker for me.

Disabling the compositer still helps a little, but only reduced it by 30%… so there is still this black flashes here and there.

Im still wondering why this flickering temporary vanished when i do 3D gaming.

For me it happens at any time. Working in Blender, Unity, playing Tarkov. I’ve looked at a few other bugs that got put into mainline and looks like if anyone checks my logs it will be at least a week or three before someone that can fix things will even notice.

I also see it alot when i work in Shotcut to Edit some Video files… when i hovering about the menue and the overlay shows up and so on… maybe it is related to powerstates, but not only… atleast thats what i guess.

You talking about that flashes in Tarkov when you in a menue or when you actual playing and running around?

I see it alot flashing when i playing Beyond all Reason and when im inside the lobby (2D) but on the 3D environment, there is everything fine… or i might just dont saw it yet.

It happens at any time. Like I said in my original post there is no workload or “thing” that triggers it more or less. I can be in menus, playing, working, coding, doesn’t matter. There doesn’t seem to be a timed cadence/interval either.

Given killing picom seems to have quelled it it makes me think there are some draw calls the new driver does that trips various things up. Just so happens on my machine picom is the most affected. That said I also never get anything in the syslogs or any other log about errors or issues when it happens. Just there then gone until the next time with seemingly no indication anything happened other than I saw it.

Hi

After doing an upgrade to the 530 driver, I encounter the same problem as you. However, since i’ve added the following kernel boot parameter, the flickering seems to be gone.

nvidia_drm.modeset=1

Without that, opening a text editor, a web browser, scrolling a web page or even watching a video, my monitor flicker 2 or 3 time every minutes (or two if i’m lucky).

But since i’ve added this to grub my monitor doesn’t flicker anymore.

Maybe, for those who encounter this weird thing, you can try that.

GPU : RTX 2080
120hz gsync monitor
OS : Debian unstable with 530-41-03 driver from experimental repo.

English is not my native language. Sorry for grammatical mistakes.

3 Likes

Yeah, looking at it more. The power states might be a consequence rather than the cause. Going to give the kernel param a go.

Yeah amazing, no more black flashes.

Thanks alot :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.