Set nano system clock

Everytime when I reboot nano, the ubuntu system clock is back reset to year 2018 which is quite annoying. When i tried to use hwclock to set, it was failed:

rui@rui-desktop:~$ hwclock -w
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.

How to set system clock permanently?

The Jetson does not come with a battery or supercap for the built-in RTC.
You may be able to add a 3.3V coin cell battery or supercap to the back of the carrier board, so that it may remember the clock.
However, the main recommended solution is to run the Jetson Nano on a network, and let systemd synchronize the time with NTP.
(Also: on systemd systems, hwclock is no longer the way to store clock – systemd replaces pretty much all the previous small unix utilities with a thick swath of new reimplementations all mushed together.)

Hi snarky, Thanks for your information, actually, when I took ubuntu system setting for clock & date, synchronize with network clock, it didn’t work. Do you see this issue?

Can you “ping” in a terminal?