Setting up wifi Access Point on TX2

Following these instructions for hostapd, I was able to get a TX2 access point working.
https://seravo.fi/2014/create-wireless-access-point-hostapd

However, with original wifi antenna, the signal strength is pretty low, the signal can only cover 3-5 meters.

Has anyone got the same issue?

Did you try indoors or outdoors with direct line of sight?

You may want to try using a signal booster or high-gain antenna to gain longer range in your environment.

Thanks for your replying

I tried indoors with the direct line of sight; there’s no block between TX2 and target devices.I just want to make sure I configure TX2 correct.
What’s the average coverage of TX2 with the original antenna?

Hello,

I have been trying to setup WiFi access point on my TX2. I have tried everything in this post:

I have also tried everything suggested in other threads but it is still not working!
I have tried with the latest version of JetPack and an older one.

What usually happens is that, when I try to connect to my AP, I get incorrect password despite me typing the right one.

Any help would be appreciated… Thanks!

Here are the error messages.

[ +0.041849] dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)
[ +0.000259] gpio tegra-gpio-aon wake69 for gpio=59(FF:3)
[ +0.005866] gpio tegra-gpio-aon wake69 for gpio=59(FF:3)
[ +0.005317] Enabling wake69
[ +0.006277] wifi_platform_get_mac_addr
[ +0.001174] Firmware up: op_mode=0x0002, MAC=00:04:4b:8c:fa:f1
[ +0.005877] dhd_preinit_ioctls pspretend_threshold for HostAPD failed -23
[ +0.003378] Firmware version = wl0: Feb 4 2017 14:39:11 version 7.35.221.11 (r623264) FWID 01-5b44953
[ +0.002647] dhd_interworking_enable: failed to set WNM info, ret=-23
[ +0.000203] tegra_sysfs_on
[ +0.068720] CFG80211-ERROR) __wl_cfg80211_scan : Invalid Scan Command at SoftAP mode
[ +0.011287] CFG80211-ERROR) wl_cfg80211_scan : scan error (-22)
[ +0.126268] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[ +0.030764] CFG80211-ERROR) wl_cfg80211_set_channel : netdev_ifidx(4), chan_type(1) target channel(1)

Hi,

So I have been trying to set up a hotspot on my TX2, and I am having problems setting it up. So I followed every step in;
https://seravo.fi/2014/create-wireless-access-point-hostapd
but for reasons, I lose access to all internet connection; both the ethernet and the wifi no longer work, and none of my wifi shows up. is there something I missed

Hi mohammedshittu1,

Please open a new topic for your issue. Be sure to update with JetPack version you used. Thanks