So unstable --- what's next?

I think I have experienced all issues regarding freezing, not booting etc I have read in other threads

What is making the jetson nano so sensitive? I have used the same tool burning many images before for both RPi’s and Odroids without a single problem. Tried both on my mac book with apple pie baker and on windows with USB Image toool

Sometimes it doesn’t boot at all, after re-applying power it may boot
Sometimes it boots but black desktop, nothing
Sometimes it boots fine, I get the desktop but when I click anywhere, it freezes, disconnecting power only way out

When it works it can work some minutes, sometimes some hours. Then suddenly it freezes

Managed to install Hello AI-World (several freezes on during the process). Luckily running some inference tests but suddenly a freeze again, getting frustrated

Most of the times it freezes by itself ---- just by doing nothing

Is it my sd cards? I use 32G San Disk Ultra. Are they not good enough?
Is it my power supply? I’m using a 5V/4A, running in 5W mode
Is it my network? Tried both wired and wifi, no difference, same problems

I think there is something in your firmware or your ubuntu distro

Hi walter.krambring,

Note that some USB cables can lead to additional voltage droop, could you get another one and try it again?

Thanks for your suggestion but I’m not powering with the usb connection (tried that as well with several usb cables/supplies)

Also to inform: my swap is 8G

It can, if I’m lucky, run for some hours but then it just freezes

Also note that a reverse protection diode through the barrel connector probably drops the voltage by about 0.2V. Thus the barrel connector might need about 0.2V higher supply to be stable.

Just some feedback; my power supply is a 5V/4A switched unit, I have measured the output (under load when connected to the jetson) and it is then showing 5.20V, should be good enough, but I will anyway purchase a new unit

If I’m lucky, the thing is running anywhere from a few minutes up to half a day. It is very strange. Most of the time it is also very hard to restart, I have to unplug power supply several times, then suddenly it might wake up

Even tried to make a new sd card based on the backup that normally happens to start, but no luck with that one

Should I suspect the sd cards are not good enough? Is it worth purchasing a better “gold version”. What is your experience? I have these 32GB cards:
https://www.ebay.com/itm/SanDisk-16GB-32GB-64GB-128GB-200GB-256GB-Micro-SD-MicroSDXC-paket-ULTRA-80MBs-/301735949767?var=&ef_id=CjwKCAiA_MPuBRB5EiwAHTTvMW1tPk43OaGY5spmS7_Z3bpMabGlDdM_9PT3yzNRdvkcBhzWjlcruhoCGzgQAvD_BwE:G:s

Is the jetson also sensitive to always have a monitor/keyboard/mouse connected to boot up reliable?

Lucky? Not for long,

The nice setup I had is not working anymore. The Hello AI, all python libraries, all work done and the thing doesn’t even boot any longer. Was running fine this morning, stopped by itself sometime today, now only thing is the nvidia logo on the screen

Seriously, this is no fun!!

Tomorrow, last chance, I will buy a new power supply & a “super high quality more expensive” sd card. If it doesn’t help, the jetson will go to the bin, I do not have time playing around with such simple fundamentals that just should work. Great idea but it feels not mature enough and if it is so sensitive to what model of power supply and sd cards, they should be included in the kit, adding a few dollars more is no problem as long as you get things that works when put together

It did not work, must be broken

Bought a new one today, inserted the sd card from the broken unit, same power supply 5V/4A

And guess what, booted up right away, been running almost 6 hours already, no interruption at all, feels much more stable than the previous

Will be a RMA, already started the process…

Hi Walter,

Would you mind if I ask the detailed SD card?

Thanks

Hi, I guess nothing special,

I have some San Disk Ultra 32GB as well as San Disk Extreme Plus 32GB (more expensive). All works without problem in the new unit, currently running since yesterday with Extreme Plus

Hi Walter,

I think so, noting special.

I’m using several microSD cards with 3~4 Jetson Nano Dev. Kits, 16/32/64 GB from Sandisk and Samsung.
Never seen as you met yet.

Probably your dev.kit is somewhat sensitive I think.

Thanks,