socketcan interface can1 not work after setup aurixcan on DRIVE PX2

before setup aurixcan the both socketcan interface can0 and can1 can work.
After setup aurixcan only can0 interface can work, can1 can not work.
aurixcan hardware interface also can setup communication.


note can0 and can1 is the socketcan interface on linux system. If enable can show by using ifconfig command

Dear duanwendi,

Can I know how to setup Aurix CAN in your side and how to check can0 and can1 interface?
Please upload the log if you have. Thanks.

Hello,
Could I ask how to make can1 active? Because candump can’t get any message from can1, but it can get messages from can0, while can0 and can1 are same when “ifconfig” and “ip link show”.
Thank you very much!

on autochauffeur tegraA can only use CAN0, tegraB can only use CAN1
on autocruise can use both of them
I use driveinstall*.run to reinstall the board both socketCAN works

Hello duanwendi,
Could you tell me which hardware are you using, autochauffeur or autocruise, please?
Do you mean reinstall the autochauffeur and then both socketCAN works?
Thank you a lot for your help!

I use autocruise

Hello duanwendi

Could you tell me how to setup aurixcan, or any documents I can refer to?

Thank you very much!

https://devtalk.nvidia.com/default/topic/1032296/faq/drivepx2-easycan-setup-guide/
you can modify the configuration program of easycan under the install directory, also can make a test of aurixCAN
below is my path
NVIDIA/Drive/5050bL_SDK/DriveSDK/drive-t186ref-linux/samples/easycan

Thanks for your reply.
I have followed the setup guide, when I run ./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a, no message return.
On my px2, when I type ip link, we can only see can0 and can1, can not see can2~5. Is it reasonable?

use the aurixCAN need to follow the aurixCAN setup process first

I have followed the setup guide, when I run ./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a, no message return.
If the aurixcan is set succeed, we can see can2~5? Is it right?

I have followed the aurixcan setup guide https://devtalk.nvidia.com/default/topic/1032296/faq/drivepx2-easycan-setup-guide/ ,but it does not work, when run ./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a, no message return. About the guide I have a small question, in note 2 it said “EASYCAN Testing (connect your device to a CAN interface, for example, CAN1/CANa)”, how to connect the can interface?

1, use easycan configure aurixcan interface, source coude under NVIDIA/Drive/5050bL_SDK/DriveSDK/drive-t186ref-linux/samples/easycan( modify the configuation file make sure your message not filtered).
2, use sample test aurixCAN ./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a

I do not have the source code folder.
It said that we can configure the config file to filter the message. If it means that I can also change the EasyCanConfigFile.conf to filter the message?
But how can I test sending message, how can I test if tegra can receive message?
Thank you very much!

you can change the configuration file to filter message.

test the configuration have two method
1, use easycan it will print the message received from aurixCAN interface and send a specify id message, pugin your device and check the message

2, use sample code to write a program to test the interface

If I use the default config file, how can I simulately test sending message and then test if aurixcan can receive message?
For example one message
MsgId : 0x140
CtrlId : EC_CAN_BUS_E
FrmTyp : CAN_ID_STANDARD
DestId : TEGRA_DEVICE_A
DestSwc : SWC_ID_CANDATA
in the config file like this. How can I simulately test sending message?
Thanks very much

Hi duanwendi
Are you Chinese?

when configuration is finished, run the configuration program can send 0x7Ax message though aurixCAN interface, and the program also print out message, filtered though the auriCAN interface.
and I’m Chinese

Now the problem is that, I do not know how to send a specify id message though aurixCAN interface, using any tools or any sample executable file? For example I define a message like this
MsgId : 0x50
CtrlId : EC_CAN_BUS_A
FrmTyp : CAN_ID_STANDARD
DestId : TEGRA_DEVICE_A
DestSwc : SWC_ID_CANDATA
how can I send this defined message?

Hi duanwendi,
Now I am blocked on testing the Aurixcan. I have tried several methods to test aurixcan communication but does not work. I am confused how to test it.
Could you please provide me some detailed steps testing aurixcan?
Thanks very much.