[SOLVED] Samples not run CUDA 9 - Nvidia 640M LE

I have a laptop whit Nvidia 640M LE and I intalled the CUDA 9 toolkit
But when I execute a example i.e 0_simple/vectorAdd I obtain this error:
Failed to launch vectorAdd kernel (error code no kernel image is available for execution on the device)
I’m using ubuntu 16.04
kernel linux: 4.10.0-30-generic

Sounds like you may have the Fermi version of 640M LE

https://www.notebookcheck.net/NVIDIA-GeForce-GT-640M-LE.72199.0.html
https://www.theverge.com/2012/3/22/2892273/nvidia-geforce-600m-kepler-fermi-mobile-specs

If so, it’s not compatible with CUDA 9. Switch to CUDA 8.

After you switch to CUDA 8, run the deviceQuery sample code to find out the compute capability of your device. If it is 2.x it is Fermi and not compatible with CUDA 9.

Ok that’s the trouble, I tried with CUDA 8 and now the samples run.

the result for deviceQuery

Detected 1 CUDA Capable device(s)

Device 0: “GeForce GT 640M LE”
CUDA Driver Version / Runtime Version 9.0 / 8.0
CUDA Capability Major/Minor version number: 2.1
Total amount of global memory: 1985 MBytes (2081619968 bytes)
( 2) Multiprocessors, ( 48) CUDA Cores/MP: 96 CUDA Cores

Many thanks