[Solved] [Ubuntu 15.04] Games crashing after installing Nvidia drivers

I’m running Ubuntu 15.04 (fresh install 2 days ago) on a desktop computer with 64 bits AMD CPU and a GTX 460M.

I’ve been trying several Nvidia drivers (all, actually) through the Drivers panel. Then I tried 2 games on Steam (which ran slowly but fine using the nouveau open drivers) and they crashed immediately.

I’ve tried looking for a solution on the Internet but both my G**gle-fu and my understanding of Linux fail me.
I’ve been, however, able to gather a few pieces of information that could help understanding my case:

Using the latest Nvidia drivers available (346.59):

Moreover, the log of one of my games begins with:

I believe the key of the problem lies in these 2 lines:
X Error of failed request: BadValue (integer parameter out of range for operation)
Kernel driver in use: nouveau

But I’ve been unable so far to find a way to correct this.
Any help or hint would be gladly welcome!

This indicates that the driver isn’t correctly installed. You probably need to follow your distribution’s instructions on how to blacklist the nouveau driver and configure X to use the NVIDIA driver. Can you please run nvidia-bug-report.sh and attach the resulting log file here?

Thanks a lot for showing interest!
I want to apologize for not producing the log directly, but I couldn’t locate this PATH directory yesterday. Of course, now that I tried harder I feel a bit silly.

Running the script sure was an interesting thing:

  • it froze the computer at some point, I had to do a hard reboot
  • I had a “ACPI PCC probe failed” error at reboot, a frightening sight but with seemingly no bad consequence
  • Ubuntu now thinks that I have a new Micon Communication 17" screen installed beside my usual single screen - I’ve never had more than 1 screen. Is it a strange side effect of installing the Nvidia drivers?

On the bright side the Nvidia X Server Settings now shows informations, it always had been blank before.

I now have to find a way of attaching the log here!
[Edit] Done!
nvidia-bug-report.log.gz (57.3 KB)

Just a little up to say that I’m still stuck and would gladly appreciate any direction regarding these problems. Is the “ACPI PCC probe failed” an actual issue? Does anyone know what it means?
Many thanks in advance!

After some investigations I believe the phantom screen comes from a misdetection by the Nvidia drivers of this tiny interface card (don’t know how it’s called) that links the graphics card to the motherboard (I own a somewhat unusual compact, fanless desktop computer).

Your attached bug report indicates that the driver still isn’t properly installed: the X driver “nvidia_drv.so” couldn’t be found, so the X server fell back to the nouveau driver:

[     5.882] (WW) Warning, couldn't open module nvidia
[     5.882] (EE) Failed to load module "nvidia" (module does not exist, 0)
[...]
[     5.886] (II) NOUVEAU driver Date:   Thu Aug 28 03:57:48 2014 +0200

Go into System Settings -> Software & Updates -> Additional Drivers and select the latest NVIDIA binary driver version and hit Apply. That should automatically blacklist nouveau for you.

You’ll have to reboot afterwards. Let’s try that first and then see where that gets you.

Thanks aplattner and jwcalla. Actually the only thing I missed was the reboot. I’m not accustomed to reboot on Linux. Everything is work fine now, problem solved!