SteamVR crashes with the standard UE5 VR template app

I tried to test the CloudXR with standard UE5 Template for VR and SteamVR crashes on the App-Startup with CloudXR-Client connected. With UE4 Template it works just fine (just the already known bug with transparency). Maybe it is related to the new OpenXR framework that they are using for the VR.
SteamVR

1 Like

Everytime i tried the OpenXR in UE4 and not the SteamVR plugin, Steam crashed.

1 Like

Should be the OpenXR Plugin, the official out of beta OpenXR Plugin will be release on UE 4.27

1 Like

I have the same problem.

1 Like

anything ???
help !

Hello,

the CloudXR backend for SteamVR is independent on the application facing API, so we might be looking at a UE or Steam issue. To verify or falsify this assumption, can you (a) run your UE project with OpenXR on a different OpenXR runtime? E.g. Oculus or Microsoft Mixed Reality? The Microsoft one has a nice desktop “emulation” mode, meaning you don’t need actual hardware to test this (Using the Windows Mixed Reality simulator - Mixed Reality | Microsoft Docs).
Test (b) would be to run your app with OpenXR and Steam but using a Steam supported headset instead of CloudXR.

If (a) fails, I would suspect the issue being in the UE4 plugin. If (a) succeeds but (b) fails, it might be Steam. If (a) and (b) succeed but you still see the CloudXR issue, we’d need the app in question to try to reproduce the issue.

@rmenzel Probably a good idea to run your test internally using the publically available VR template from the UE5 project and confirm when this is working on your end.

Hello Laurent,
I build the UE5 VR sample and tried to run it with SteamVR (with an HTC Vive) and it crashes as well at start (just saying “Fatal error!”).
As this was without CloudXR, the issue must be in either UE5 (which is in beta as I understand it) or SteamVR.