Terminal Window on Jetson nano (JetPack 4.5.1)

Hi,

Just a few days ago, i discovered that the terminal window starts up on the far most top-left corner. The left side bar as well as the top-bar that shows the icon are blocking the view of the terminal window.

While the terminal window can be moved around by using ALT+F7. This is still pretty annoying since i have to do it each time i start up the terminal window.

I think it has got to do with the regular updates but i am not sure.

I am not sure whether anybody faces the same issue and would certainly be glad if someone can offer any resolution to this issue.

Benjamin

Not quite sure what is the problem here. Can you take a video for what you see over the screen?

A screenshot showing the terminal window that pops up at the top left corner.

I am not quite sure about your question.

Are you saying that “every time you reboot the device, open a terminal and it will always be on the wrong place and gets blocked?”

Yes, exactly like you described it.

Its like a default docking place for the terminal window each time it starts up

@WayneWWW …attached video just to give you a better understanding.

What I really care about is how did you hit this issue?

I tried on every of my jetson device but didn’t hit such issue. Did you change any configuration?

Yes, i know what you mean. It puzzles me just as much.

No, i did not do any configurations on my device.

I tried searching on the web for a solution. Mostly point it to GNOME which i did not install.

Why did you not install gnome? I mean this is the default desktop we install from jetpack.

This contradicts to your comment “No, i did not do any configurations on my device”.

i did not know gnome was the default desktop installed from jetpack

It was not meant to provide contradicting answer, but i did not do any configuration for the desktop

Does this issue happen from the first day you use jetson nano?
I mean you installed pure jetpack to the board, booted up and this issue exists?

This issue was not there when i started using it. It only happened along the way when i installed the regular updates and this happened.

I am not sure which update, but this happened only a few days ago.

One suggestion is that if this was due to an update, then from a newly flashed system without updates having run, save a list of packages via “dpkg -l 2>&1 | tee log_no_update.txt”. Then update (I doubt you could just update in steps, but if you could, then I would suggest doing so), and make a similar log with the update. When you find a stage where the terminal is covered by the icon bar, then compare the list of packages. If you have a package you are “suspicious” of, then you could see what happens when you revert that package.

Note that you do already have a package version which is failing, so you could save the current package list for this “failed” condition before you ever start flashing. Also, if you have any valuable work, and if this is an eMMC model, then you could first clone. If this is an SD card model, then you could simply use a different SD card for testing. More information on whether this is an SD card model or eMMC model would help in some cases since SD card models also have QSPI memory.

Thanks @linuxdev for the advice. This would involve using a new flash SD card to make comparison on non-updated and updated to try and spot the problem but however its not meant to solve it ?

I guess my only option now is to backup my data, re-flash the SD and move on from there.

Yes, it is meant to find which packages changed so that we could figure out which one was related to the issue. A real solution would probably be to either blacklist that package from update, or to have a package which is edited to fix the issue. The former is of course easy, while the latter depends on someone else finding out how to fix the package.

So far as backup goes, do you have a second SD card? In that case it is simple since you can simply keep the original SD card unmodified. If you have only one SD card, then you’d need something like “dd” to save a copy of the SD to a host PC which has lots of extra disk space.

Thanks @linuxdev and @WayneWWW for your time to try to help.

I see that this is not going to be quick fix and trying to spot the package by installing updates in step which i doubt i can do and even if i find it, may not necessary get that someone to fix it . It also seems to me that this is not a common problem and may not be due to regular patches after all and see no point in pursing this any further.

i do not have a separate SD, so will just back-up my data, re-flash the SD and move on from here.

Thanks again.

Not sure at all, but you may try to clear compiz cache and reboot:

rm -rf ~/.cache/compizconfig-1
sudo reboot

@Honey_Patouceul . Thanks for the advice.

No, it does not remove the problem. Issue remains after reboot.