The Dreaded Black Screen on boot: Ubuntu 22.04 + 2080ti + 515 drivers

I tried, I really tried (I promise) all of the solutions I could find in threads on this forum, and it pains me to have to post, but alas, here I am.

I’m attempting to get a fresh installation of Ubuntu Desktop 22.04 working with my desktop running a single 2080ti, but I can’t make it past booting.

I’m running a custom build machine with a Gigabyte Z490 Vision D (w/ latest firmware). I’ve removed old drives, reinstalled new drivers, and everything appears to be configured properly, at least as far as various utilities report. I’ve tried with both 515 and 510 drivers, and no-go.

I AM able to get to a terminal with Ctl-Alt-F3 and I am able to get into the window manager when I remove all Nvidia drivers (with huge blocky windows at 1024x768 or something like that), but with the drivers installed I’m stuck.

Attached is my nvidia-bug-report.gz – I would hugely appreciate it if someone could take a peek and perhaps point me in the right direction. Many many thanks in advance.


nvidia-bug-report.log.gz (274.7 KB)

Nvidia driver and gpu look fine, the Xserver is starting correctly, there’s just no gnome-shell starting or it’s crashing.
Please check for gnome-shell messages in journal.
sudo journalctl -b0

Thanks for helping me debug this @generix. Here’s the output of journalctl filtered by “gnome” – I can’t quite tell what’s a real error message vs. normal log noise. Appreciate the second pair of eyes… (4.3 KB)

Odd stuff, gnome-shell reports it’s running but it’s not visible on the nvidia gpu. Does switching vt back and forth to vt2 yield an output?

Just to be clear - by “switching back and forth to vt2” do you mean Ctl-Alt-F1,F2,F3, etc? I’ve tried that and while I can get a text-only login prompt, I cannot get any sort of Gnome/window manager output.

While it shouldn’t matter, does removing “nomodeset” from kernel cmdline change anything?

I have the same problem with 515 driver + Ubuntu 22.04 + 1660Ti. nomodeset does change anything but allows me to see grub screen when it is set to zero, otherwise grub screen is black almost always and I have to blindly choose where to boot windows or linux

Any chance your monitor is connected via display port? I kept running into this and found once I hooked up via HDMI it worked. Switched back to DP and it would remain stable for multiple reboots then randomly stops working again. Back on HDMI and have not had it occur since (3+ weeks).
Of course I have only recently made the switch to Linux, so I could be completely off my rocker.

Ahh interesting - that’s something I hadn’t considered trying. I am on DisplayPort. Although my monitor (LG Ultrafine) is DP-only, so trying out HDMI may be a challenge. I’ll see if I can hook up one of the other monitors in the house via HDMI and see if that changes anything.

Same issue. Ubuntu 22.04.1, latest kernel 5.15.0-48, latest nvidia-driver-515 for Nvidia A2.
It shows black screen on boot, but if I do ctrl + alt + f4, it allows me to get in the terminal.
Then if I do startx, it launches the desktop and everything is fine … right until the next reboot

Setting nvidia-driver-510 does not help, but setting nvidia-driver-470 fixes the problem…

1 Like

Only created an account at NVIDIA to say THANK YOU. Same problem, but with RTX A4000.

1 Like

On ubuntu 22.04.1, tried so many different things. Always resulted in a kernel panic “out of memory”. Until now, only option was to boot from a previous kernel in rescue mode and move to the default xorg nouveau driver.

Installing 470 is the only thing that has worked. Thanks.