The scene imports usd, and the usd disappears after "collect asset"

I encountered some problems in scene production. I created two scenes, one is Home and one is car. And saved it as USD. However, when I open the Home scene, and import car, it is fine. So I “collect asset” with “Home.usd+car.usd” and reopened “Collected_Home”. It didn’t work as I thought. Car disappeared. I can’t find the reason. I hope I can get some Help, I would be very grateful.


@fsb0147 do you mind walking through how you are collecting assets? screenshots of the setting could be useful. also, i was able to follow along until you “‘collect asset’ with ‘home.usd + car.usd’ and reopened ‘Collected_Home’”. how many total files are there? because there’s “car_car” and “car5” USD as well. what version of Issac Sim are you using?

that said, i tried to repro based on your structure of one USD containing one payload and another payload nested within. and didn’t have any issues when using the collect asset extension in OV Code 2023.1.1.

@Simplychenable Thank you very much for helping me solve this problem. I will answer your questions first and upload more screenshots.

  1. The version I am using is 2022.2.1, because the latest version I received is 2022.2.1, and I cannot see version 2023.1.1.

  2. The collection method I use is Home.usd, right-click “Collect Asset”, and in the options, I have tried them all, and selected “Group By MDL”, “Group By USD”, and “Flat” in Flat Collection. Fortunately, it can collect “Home.usd+Car.usd”. But I encountered a new problem, the material problem.

3.Home.usd was imported from Unreal. Some of its materials are incompatible, resulting in red color. Then I did some work and made some very basic PBR materials with Unreal, exported them to my disk “D:\OM\Materials_Pbr\XXXXX”, and used them in Home.usd, and it worked very well. But when I “Collect Asset”, it doesn’t work, the materials are lost. I tried many methods, but nothing works. I don’t know what the problem is. It now shows red and white materials. You can see my screenshot. I guess the white one means that the texture cannot be found. The red one means that the MDL cannot be found. But I don’t know how to solve this problem. In addition, USD Paths is turned on and used by default.

I hope you can help me solve my doubts, thank you very much!

okay, you made a separate post regarding the material issue, so i’ll leave that there so we stay on task regarding the USD disappearing issue. since the issue is the car disappearing, let’s start there.

what’s in the “car5” payload/usd? can you open that USD and take a screenshot of the stage (it’s best if you can expand every stacks)?

if you feel like skipping the missing prims issue when using the “collect asset” extension because you have a handle on it with “flat collection”, we can hop into the other thread regarding materials.

@Simplychenable OK, I have solved the problem of missing prim, but I have not solved the problem of missing materials. I hope you can help me. Let’s discuss this problem in another topic to help people who encounter this problem.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.