Isaac Sim Crashes when I try to open a saved USD

I am running through the documentations for Issac Sim and when I try to open my saved USD, the application crashes. Need help and advise on how to fix this.

Note: I do not have any applications open in the background and have full memory capacity available. Besides the file is too small for it to cause a crash due to memory.
Test-Robot.usd (14.9 KB)
kit_20230824_124835.log (1.4 MB)

1 Like

@herman.theng the dev would probably ask for the USD file to repro when they get around to this thread.

in the interim, can you give a bit more information on how the USD came to be? was it saved from Issac Sim? what material do you have on it? also uploading the most recent log file would help them troubleshoot. You can locate it in the folder here:

  • Windows - C:\Users\%username%\.nvidia-omniverse\logs\Kit\Isaac-Sim
  • Linux - ~/.nvidia-omniverse/logs/Kit/Isaac-Sim

@Simplychenable appriciate your prompt response to my query. I tried moving the file to the directory suggested in linux but it still causes the crash.

Alittle more information about the USD file. It was a simple model I drew in Isaac Sim with very parameters included. You can say it is just a stick man layman terms. I saved it on desktop then tried to open it in a new stage it just crashes. I attached the USD in my question thread.

Also, I am new to omniverse, may I know which log file to share?

oh, i am afraid you may have misunderstood my direction. you didn’t have to move anything into those directories listed, actually. the directories provided location of the log files, which could be useful when troubleshooting the reason behind the crash.

depending on your OS, you will want to upload the latest and most recent .log file found in that folder to this this forum thread. note that if you have multiple versions of Issac Sim installed, you will see subfolders with the app version as the subfolder name. if you are using 2022.2.1 at the time of the crash, that’s the folder you will want to dig into.

once uploaded to here, the dev team can then download, review, and report back their findings. it’s likely that they will inquire additional information after that, but providing the log is generally a good first step.

upon opening your USD file on my end, it doesn’t seem like it’s an issue with the app or file itself. so that’s where the log would come in handy as it would provide information to your hardware specs and such.

another thing you can verify is whether or not the crashing also occurs in other apps such as Composer so we can determine whether it’s specific to Issac Sim.

@Simplychenable appriate your response. I tried to load the USD file on windows and it works but in my booted Linux it crashes. Maybe due to an error in set up.

Will upload the log file for the dev team to review, hopefully they can help to point out the cause or errors due to the setup.

Hello, thanks for posting, I am having the same issue. I can confirm that the problem happens whether using Isaac Sim or Omniverse USD composer. A strange characteristic I found with this bug is that it will sometimes work if you drag a USD asset into the scene instead of opening the file directly. It appears to be related to carb loading functions.

I reinstalled cache, USD composer, Isaac Sim but still have the same problem. I have uploaded a log file and a usd file. Hoping a solution is found soon so I can continue to use Omniverse.
is_tutorial.usd (9.0 KB)

kit_20230829_122723.log (1.4 MB)

@seyi.ooj how often do you experience crashes? i see a warning in the log pertaining to PaintTool right before the crash. and upon checking your uploaded USD file, there are few remnants from using the Paint extension (see below), so i am wondering whether you have use for them or intended to have them in your stage? if not, can you try getting rid of them to see if that helps with crashing when using this USD?


of course, if you are experiencing other scene crashes not using this particular USD, it could be something else altogether.

Thanks for your reply. I have not seen crashes on my end specifically pertaining to the paint tool. I have this issue in every USD file, regardless of whether it uses the paint tool or not. I uploaded that USD as it is one I used for working through some Isaac Sim tutorials, but other USDs have the same issues. I have tested the files on a windows machine install of Omniverse also, and they appear to load without issue there.

i see. are they separate machines (Windows vs Linux)? if they are, have you tried the driver version that is recommended by Issac Sim on Linux? there is also Linux troubleshooting doc that you could take a look at as well.

My current driver version is Driver Version: 535.86.05, so I can try to change to the one currently reccomended (525.60.11) and report back whether this has caused any changes.

Hello all, I can confirm changing to the recommended driver version (525.60.11) fixed the issue. I still have various warnings in the console, but I am able to load a USD file from the file manager without Isaac sim crashing. Thanks very much for the help!

About the warnings still occurring when loading files, they are associated with the omni::ui::Gpu resources Cache such as:
[Warning] [omni.ui] omni::ui::GpuResourcesCache: trying to release non-existent cached GPU resource '~.local/share/ov/pkg/isaac_sim-2022.2.1/kit/exts/omni.kit.window.filepicker/data/thumbnails/usd_stage_256.png

1 Like

i am pretty sure those warnings won’t impact the overall performance/stability of Issac Sim. i get them frequently as well in other OV apps like Composer and Code.

I have the exact same issue when I’m trying to open a USD file in Linux that I created on Windows.

Does Nvidia plan to fix this issue and support newer drivers?

I’m currently testing downgrading the driver from 530 to see if that fixes anything.

Hi @whoishoa - are you seeing this issue even after updating to latest Isaac Sim version?