The time of Tx2 keeps resetting when poweroff

Hi all,

I am now facing a problem with TX2 working with Auvidea J120 extension board. After power off and off the power supply for some time and restart the TX2 again, the time of the system is no longer correct. I am using ros system now and use rosbag log. If the system time is not correct, it will create a lot of trouble. Anyone knows how to solve it? Thanks a lot!

Best wishes,

I don’t know about that particular carrier board, but in general a battery backup would be needed for longer duration shutdowns. The traditional way of dealing with this on carriers without battery backup is via a supercap.

There have been some past posts on other boards of how to connect a battery backup, so I suspect there is the same possibility on your J120 (I don’t know what it would be though).

As a workaround if you have network access you’d want to enable NTP (network time protocol). I am assuming that if this is on a drone or robot type device you won’t have outside world networking available, but if you have a Linux host available during boot of the drone (e.g., via WiFi), then the host could forward its time and date information via NTP and have the Jetson set its time from that.

1 Like