Throttle not responding for Jetracer (Waveshare Kit) running on Jetson Nano

I have the Waveshare Jetracer AI Kit, and when I run the Jetracer throttle function (car.throttle = #) in the basic_motion Jupyter Notebook, the 2 rear motors for moving aren’t spinning. Despite this, the steering servo motor is working fine and responsive, and I have checked the wiring for the 2 motors and it seems fine. I have uninstalled and reinstalled the Adafruit-PureIO libraries multiple times, as suggested by Waveshare, but that didn’t solve the problem either.

Basic_Motion code: https://github.com/NVIDIA-AI-IOT/jetracer/blob/master/notebooks/basic_motion.ipynb
Waveshare Jetacer wiki: https://www.waveshare.com/wiki/JetRacer_AI_Kit

Any suggestions on how to debug or get a response from the 2 rear motors would be appreciated.

Thanks

I too have same issue.

Same here, any solutions?

same thing here!

Same issue here…

Same here… Any one solved it?

Sorry for the delayed response (haven’t checked on this site in a while) but there are some fixes. I had received some advice from another developer on the Jetracer Github and it seemed to work:

Waveshare actually uses a forked version of the main Nvidia-AI-IOT repository, so you need to use the code from this version and not the main version. The correct repositories can be found here: https://github.com/waveshare/jetracer

To me it seemed like the only files that were different from the repositories were nvidia_racecar.py (and maybe racecar.py and init.py), so I just copy pasted the new code for those files, shutdown and restarted the kernel and the throttle is now responsive.

For further information I would go to this link where the conversation on Github started: https://github.com/NVIDIA-AI-IOT/jetracer/issues/66

1 Like

To share what I did.

The first step you do is a software patch, step 5 of this link: https://www.waveshare.com/wiki/JetRacer_AI_Kit
And next, test your DC motors. If you feed power directly, they should move any direction.
In my case, the DC motors do not move even 12V direct feeding at all.
I had to buy genuine products in local.

1 Like