Trying to run VScode yeld no results - Xavier NX + JetPack 5.0

Hello, super new to Linux user here :-)
I have installed VScode on jetson nano successfully in the past, but after buying a xavier nx, i simply CANNOT have VSCODE to run…
When i try to run using the icon, nothing seems to happen, when i try to run using terminal, it just does not open and just returns to a new line on the terminal.
When i try to run it using --verbose, nothing happens and the terminal “freezes”.
I have tried to search for similar issues here and what i could see i have tried with no success (mostly people running in amd and not arm…
ANY help would be appreciated :-)
Thanks

2 Likes

Same here, VS code can’t launch (no response or error message) after installing on JetPack 5.0.

2 Likes

I’m in the same boat as well.

1 Like

Still no luck here 😔

Thanks to everyone who has contributed to this thread. I have filed an enhancement request for the Jetson team to review the ‘code’ requirements on Jetson platforms, and determine what changes/enhancements are required to support this IDE.

try code . --no-sandbox

as workaround

1 Like

So it’s working on JetPack 4.x, but not on NX with JetPack 5.0 DP?

I was never able ro make it run on the jetson xavier
I have made it run with no issues on a jetson nano and a jetson tx2 but so far no luck on a jetson xavier nx

Will do ! Thanks ! Will probably be next week though as i am out of town

This was the case for me.

Hi GaramJF,

Please upgrade Xavier NX to JP-5.0.1 DP via SDKM and follow below steps to run VScode.

  1. Download VS Code from Download Visual Studio Code - Mac, Linux, Windows
  2. Install the downloaded package through sudo dpkg -i <file_downloaded>
  3. Execute code to run the VS Code IDE.
1 Like

Good afternoon ! i have installed JP-5.0.1 DP, downloaded and installed VSCOde as instructed (However using sudo dpkg (no dpkp) -i and unfortunately i am still getting the same failure, when typing code, nothing happens. i was able to run using code --no-sandbox though.
Is there log files i could look into when i just type code and nothing happens ?
Thanks !
carlos.

Hi GaramJF,

We tried JP-5.0.1 DP, confirmed VScode working.
Are you download VS Code from Download Visual Studio Code - Mac, Linux, Windows?
$ sudo dpkg -i ./code_1.67.1-1651840704_arm64.deb

Hello Thanks for the response ! the build available at Microsoft link you’ve sent is a newer version code_1.67.2-1652811872_arm64.deb, maybe that is an issue ? i will try to find exactly the same version as you mention on your response.
I appreciate you and others support !
Carlos.

tried with exact same version (code_1.67.1-1651840704_arm64.deb) and still get nothing when just running “code”
“code --verbose” does not return nothing and seems to run forever.
“code --no-sandbox” works
is that any actual difference on running with the no-sandbox option ? cuz if not i may just run it like this everytime, i do not care honestly.