AGX Xavier, vs code can not work on jetpack 5.1.2

Hi, I’ve just update Jetson AGX Xavier to jet pack 5.1.2 and ubuntu up to 20.04, everything is fine but I cannot use VS code. I tried lastest vscode1.8 arm64, after installed, it did not work. I tried ver 1.5 arm64 this time I could use it for 1 hour, then I can not use. When I double click on vs icon, nothing happened. What should I do now ?

akira@yuri:~$ sudo apt-cache show nvidia-jetpack
Package: nvidia-jetpack
Version: 5.1.2-b104
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-jetpack-runtime (= 5.1.2-b104), nvidia-jetpack-dev (= 5.1.2-b104)
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_5.1.2-b104_arm64.deb
Size: 29304
SHA256: fda2eed24747319ccd9fee9a8548c0e5dd52812363877ebe90e223b5a6e7e827
SHA1: 78c7d9e02490f96f8fbd5a091c8bef280b03ae84
MD5sum: 6be522b5542ab2af5dcf62837b34a5f0
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

akira@yuri:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.6 LTS
Release:	20.04
Codename:	focal

Try using the --no-sandbox flag to launch vscode. I had this problem on my Xavier.

1 Like

Please try marcwester’s suggestion. The same method is proposed in Jetson Xavier NX FAQ

Q: VS Code is not working on Xavier NX

1 Like

Thank you so much, it solved my problem, but how can you know that and how does it work ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.