VS code can’t launch with JetPack 5.0

Hi, I am sorry to repeat the same problem as GaramJF and Superware2 mentioned here: VS code can’t launch (no response or error message) after installing on JetPack 5.0.
I set this topic because I have not seen any reply yet.
I tried both “apt” and “dpkg” vscode installations. The result is always: successfully installed but failed to start. Please help me. Thank you.
I use Jetson Xavier NX Developer Kit.

2 Likes

Have reference to below link.

Thank you for your kind reply.

I once installed vscode on JetPack 4.6 and it worked well.

My problem is that I cannot use vscode on JetPack 5.0:

I could successfully install on JetPack 5.0 but failed to start it.

For example:

if I type the command in a terminal $ code –version, it will show: 1.67.1 …arm64. However, when I start the code

$ code, then it just does not open and just returns to a new line on the terminal $.

I can also find the icon on desktop but I am unable to use it.

I really need some help. Thank you.

System: Jetson Xavier NX Developer Kit and ubuntu 20.04.

Suppose this problem could be the software for different Ubuntu version issue.
Do you ever have VS code working on any other platform with Ubuntu 20.04?

I have same problem in vscode installing to xavier nx with jetpack 5.0

Of course!

Additionally, according to Wikipedia: “In the 2021 Developers Survey, Visual Studio Code continues to be ranked #1, with 70% of the 82,000 respondents using it”, it probably has ~20 million users worldwide (had ~14 million in January 2021).

Please investigate, thanks!

Yes, I have VS Code working on Raspberry Pi 4 Ubuntu 20.04, Ubuntu 21.04 etc. It needs to work here and we need to figure out why ASAP.

Thank you for your kind replies.
Hi, Superware2, did you finally find the solution? If so, please help me. Thank you.
I cannot start vscode on JetPack 5.0, but on JetPack 4, it works well in the same system. I am not sure it is a bug of JetPack 5.0, but I have to flash back to JetPack 4.

launch using

code --verbose

to see if there is any distinctive error

nvidia probably broke sandboxing with chromium on this release

Just tried this. It seems to just freeze without ever launching the app.

1 Like

How are people here installing vscode? Do you have a reference to the download and install of the arm64 version of vscode?

A previous version, e.g. 1.50.0 started without error.
wget https://update.code.visualstudio.com/1.50.0/linux-deb-arm64/stable -O stable.deb
sudo dpkg -i stable.deb

2 Likes

1.51.1 also available

1.65.2 also available

HI, istvan.petras, itsklee, tolbae
Thank you very much for your kind and good solutions. I will try it.

I have the same issue… did you try it out?

1.50 works, great. Thanks!

1.65 is preferable because some plugin does not work with 1.50