Latest Visual Studio Code doesn't display GUI

Anyone know what is up with the latest ARM64 versions of Visual Studio Code?

I have version 1.50.0 running fine, but newer versions 1.69 and 1.70 don’t display anything on the screen!?! No error is reported when running from a bash terminal, and several code instances show up with ‘ps -A’, but nothing comes up on screen.

Maybe try J5.0.2(r35.1) that build in ubuntu 20.04

I’m not sure what the heck that means. Do you want me to build it myself from git or something?

I am talking about the released versions from Microsoft’s web site that get pushed to you automatically via software updates (v 1.71, just released, still doesn’t display anything, btw).

I update the BSP to J5.0.2

Oh, I see – J5.0…2 is the L4T BSP, not the version of Microsoft code?

Is there anything I need to do other than ‘sudo apt update’ and ‘sudo apt upgrade’ to install this?

I saw that code v1.71 was available for upgrade, but when I upgraded I didn’t have any better luck – it still doesn’t display anything. I had to roll back to v1.50 of vscode.

Thanks for trying to help, but your responses are very cryptic and I am not sure what you are asking me to do.

I would suggest updating by sdkmanager.

I just installed Jetpack 5.02 a few days ago. That is when I noticed this problem.

But I will try it again.

Ah ha! I discovered that visual studio code 1.71 will start if you use “–no-sandbox”. I have no idea what that means or what all the side-effects are, but it does let you use the editor. It seems to have something to do with Chromium’s Electron Sandbox.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.