Turning off DLSS by default in Unreal Engine 5.3 and getting current DLSS mode


Is there a way to turn off DLSS(3.7) by default in Unreal Engine 5.3? It seems like it is turned on by default but I would prefer it to be turned off(and turning it on runtime later).
Is there also a way the get the currently used DLSS mode? I can’t find any Blueprint node which would return the current mode used.

Kind regards,

Hello @papp.szilard and welcome to the NVIDIA developer forums.

If the DLSS plugin is enabled, then, depending on the screenpercentage used and whether super resolution is enabled in global project settings, it will default to one of the DLSS presets.

But all the details on how to enable or disable it, how to integrate DLSS specific blueprints into your project and much more can be found in the extensive documentation that is part of the plugin you downloaded. For example DLSS_Super_Resolution_Quick_Start_Guide.pdf contains all the basic information about the things you asked above.


Hi Markus,

Thank you for the quick response.
I guess I would need to add n.NGX.DLSS.Enable 0 to DefaultEngine.ini to disable it by default?
I haven’t found a blueprint node that would just tell me which one is the currently used mode to be honest.

Kind regards,

I am afraid r.NGX.DLSS.Enable is read-only. There is a good reason for that, I just can’t find right now what it was exactly.

In any case, I am not the UE expert but if I open the sample project that is also part of the DLSS plugin package and do “Find in Blueprints” with the search term DLSS I get a lot of results, some pointing to the blueprints that control the on-screen DLSS stats when you run the demo project. I hope that might help.

The DLSS_Super_Resolution_Quick_Start_Guide.pdf only states n.NGX.Enable as read only and does not mention anything about n.NGX.DLSS.Enable.
I searched for all the DLSS nodes before, but none of them returns the currently used mode.

You are right regarding r.NGX.enable vs r.NGX.DLSS.enable I guess, not quite sure right now.

I’ll see if I can get someone more familiar with these to comment or give advice.

Meanwhile, did you check out the Webinar series we have on the different UE features? Maybe you find some helpful answers there as well.

Hi Markus,

Thank you for all the help.
It seems like adding “n.NGX.DLSS.Enable=0” to the DefaultEngine.ini disables DLSS on start-up.
Doing that revealed some weird behaviour though. Once I enable DLSS, I’m not able to properly disable it anymore.
By default, when AA and DLSS are both off, I’m getting ~190fps.( At this state I can see aliased edges.)
Enabling DLSS and Setting it to DLAA mode makes it run ~110fps.(aliased edges gone)
After setting DLSS to anything other than “Off” and then trying to turning it off again (Setting the DLSS mode to Off, and calling “Enable DLSS-SR” with enabled input set to false), I’m still getting ~110fps instead of the original ~190fps, and I can see no aliased edges(so it seems like it’s still running on DLAA mode, even though running n.NGX.DLSS.Enable in the console returns 0).
Any thoughts on this?

Kind regards,