DLSS is not working in Unreal Engine 5.0.3

A developer support question:

I downloaded the DLSS plugin version 5.0.2+, then unpacked the zip file, and moved the DLSS folder to the Engine\Plugins\Marketplace directory. After that, I turned on the DLSS plugin in the Plugin menu in UE, and then rebooted the engine. But, both in the preview and in the simulation, the DLSS is not working (framerate does not change at all).

I work in perspective mode in Lit, in the DLSS parameters I turned on the ultra performance mode, which soaps the image in the viewport, but the frame rate indicator does not increase. All videocard drivers are updated.

My specifications: Laptop HP Pavilion Gaming 15 R7-5800H 16GB RAM 1024GB SSD GeForce RTX3050Ti.

I’m asking for help with DLSS plugin activation, thank you.

First of all I would like to recommend that you have a look at a recent Webinar we did:

Registration is free and the content might shed some light on what could be different between your setup and a fully working one.

Another thing that you should double check is that you are actually enabling a scaling factor. Without upscaling there will be no performance difference since DLSS does not have to do anything. This might seem obvious, but I have seen people overlook this detail.

What is scaling factor? Is it resolution scale? No, despite the resolution value, DLSS does not work.

First of all thank you for joining the forums!

I am not the UE expert, so I will reach out to some who can better explain how to correctly set up image scaling.

Meanwhile, could you check the Troubleshooting part in the Quickstart guide that comes with the Plugin download please?
It has instructions on how to share log output with us so we can get a better idea of what might go wrong in your setup.
Also check the part about “Screenpercentage override” which has caused some confusion in the past.

Thanks!

Hey @Stan_GameDevEnjoyer a quick follow-up.

Please disregard my comments about scaling, the DLSS sample project takes care of that automatically.

If you enable DLSS logging and look at the Output Log as described in the Quick Start guide you should look for lines like these:

LogDLSSNGXRHI: Creating NGX DLSS Feature SrcRect=[0x0->679x276], DestRect=[0x0->2038x826], ScaleX=0.333170, ScaleY=0.334140, NGXPerfQuality=UltraPerformance(3), bHighResolutionMotionVectors=1, bNonZeroSharpness=0, bUseAutoExposure=1, bReleaseMemoryOnDelete=1, GPUNode=0, GPUVisibility=0x1

In this example I have UltraPerformance enabled and DLSS scales up from 679x276 to 2038x826.

I suspect that you used the UE5 built-in FPS display, because that does not seem to show any performance change just as you mentioned.

But when you start the project in standalone gaming mode and use the GeForce Experience Game overlay to display statistics (For a default GFE installation this is ALT+R), you will definitely see the difference. In my case on a 3060TI on a 240Hz monitor the sample scene showed 240FPS with DLSS UltraPerformance while it only reached around 110 with DLSS disabled.

I mentioned this slightly confusing situation to our developers.

Thanks for bringing this up and I hope my suggestions help!