TX2 cannot be turned on not writing through dangling symlink 'etc/resolv.conf'

not writing through dangling symlink ‘etc/resolv.conf’

cgroup:cgroup2:unknown option “nedelegate”
random:crng init done
random:7 urandom warning miss due to ratelimiting

Not sure what your error is it. These 3 lines also appear when normal boot.

Do you connect your tx2 to a hdmi monitor?

A note on the topic: “/etc/resolv.conf” is a symbolic link to “/run/resolvconf/resolv.conf”. The “run” directory is from a systemd query of the DHCP server. If the query process/software fails, or if DHCP fails, then it is possible that the “/run” content won’t exist. It is also possible, if something in the DHCP chain fails in an unusual way, that systemd may have issues coming back up (perhaps filesystem corruption).

Simply having no DHCP response would not have this issue, the “/run/resolvconf/” directory would exist even if there was no response.

I won’t be able to tell you what is causing it, but if you have any kind of modification to DHCP or networking, and especially if that is in combination with something which might cause DHCP to fail (perhaps removing the wrong package), then it could be “/run/resolveconf/” does not exist, and then there can be no sym link to the “/run/resolvconf/resolv.conf” (both resolvconf in “/run” and the “resolvconf/” subdirectory must exist, but I suspect one of these is missing). This would define a dangling sym link if pointing to missing content.

In the end, if you do not know of some specific cause, you will probably end up flashing again rather than finding some easy fix.

how did you solve it?

Can you help me please to solve this problem ?

This may not even be a real problem (sometimes those messages are just from some stage of boot where the given item is not yet able to configure). Are you having issues beyond just the log message? For example, does networking fail, and if it does, describe your wired and wifi networking, your particular L4T release (see either “head -n 1 /etc/nv_tegra_release” or “dpkg -l | egrep nvidia-l4t-core”).

I also have this error.
It keeps rebooting while booting and is basically stuck.

keeps saying could not set regular OCR - not sure what it means

You should probably start a new forum thread. Be sure to mention if your carrier board is from a third party, or if this is a dev kit. Also mention any version you might have flashed.

I actually solved this by flashing it again.
But when I tried flashing through windows device, through jetpack 4.4 and virtualbox with ubuntu 16 or 18.

So I used host linux as parrallel linux by macbook pro(ubuntu 18) and exactly same settings,
and there was no problem and it became much faster.

So I guess this was because of virtual machine.

2 Likes