[TX2] Couldn't Flash my Jetson TX2 - Where is the System Configuration Wizard?

I couldn’t flash my Jetson TX2. I entered the Ubuntu Desktop with default login credentials. There was no init setup process.
I haven’t set my username and password, nor agreed to terms and conditions. Running “lsusb” on host, “0955:7c18” (NVIDIA Corp) was not detected.

If the Jetson is in recovery mode, and the micro-B USB cable is used, then a regular TX2 should show up with the “lsusb -d 0955:7c18”. This tends to fail if using a VM host.

There is no system configuration wizard per se, but there are menus within the JetPack/SDK Manager GUI on the host PC (what the GUI shows depends on the stage of either flash or package additions).

Note that the addition of name/pass is from the first boot of the Jetson after the flash finishes, and prior to adding new packages. When fully booted the lsusb won’t show up, at least not as a flashable device.

You might mention more details on where you are stuck or a specific step you’re interested in knowing more about.

Yes this is not a VM host. After the “lsusb -d 0955:7c18”, still no result

Host components have been installed. Jetson OS image installed, but all rest pending for flash.

I’ve been trying to flash (using the default name/pass and IP address but the SDK manager “Could not detect NVIDIA Jetson device connected to USB”.

In error prompt description, “Verify that:” #1 TX2 is connected to host machine - yes, micro-B USB from dev kit (data cable); #2 Jetson’s Ubuntu is running - yes; #3 Ubuntu “System configuration wizard” is complete on the device - not yet how should I complete this step?

I have same issue here. I used SDK Manager to flash Jetpack 3.3.2, Jetson TX2 with a HDMI monitor.
After OS flash finished, Jetson enters Ubuntu immediately, no System Configuration wizard, no login screen… Have tried to re-flash several times…

There is no longer any default name/pass. This is what the system configuration wizard step is about, and it runs on the Jetson itself on first boot after a flash. You will need an HDMI monitor and keyboard connected, and during that boot you should be asked to add the name/pass. Following this you could continue.

On a related note, the recovery mode lsusb is not intended to show up on a booted Jetson. However, from the host, if you run “ifconfig”, then you should see an interface with address “”. You should also be able to “ping”. If this works, then networking has been set up.

Due to needing an account for ssh file copies, if no account was set up, then you won’t be able to succeed at the steps which follow.

There are times when first boot does not offer to add an account name/pass, but I am unfamiliar with the causes of this. You may want to use this script to add a name/pass to the flash software on the host side instead…this would cause the account to be created during flash instead of during first boot:

One issue which people sometimes run into is that the Ubuntu host PC may be set up to not allow the USB virtual wired ethernet until the user intervenes and accepts the interface. If “ifconfig” does not produce an interface with “”, then this is likely the case. Even with this in place, if the host PC has custom firewall rules, then it may be that the firewall also blocks the address.

Hello, linuxdev

My jetson-tx2 is just the opposite of them. After I flash the tx2, I enter a setup wizard. After I set up it, the wizard runs by itself. However, compared with other people, my jetson-tx2 lacks the step of “applying setup” and has the step of “writing to log”. Then the setup wizard window closes automatically. The system has no response. Click root > logout and shutdown There is no response, can only power off and restart, but also entered the setup wizard, has been circulating, can never enter the system desktop

You’d need to post a boot log from serial console. See:

You’ll also need to say which L4T/JetPack version you are using to flash, and if you have a keyboard and monitor attached during the flash. Most likely there will be a need to try flashing again. However, after flash there have been a number of people who could not get the account setup, and merely cycled power, followed by the account setup then starting. Don’t know if that will help, but if account setup fails immediately after flash tries to boot, then you might reboot it and see if it then runs correctly.