Ubi-usersetup crashed after image based ota update

I am studying image-based ota update and use xavier NX som board P3668-0001 (emmc version) and p3509-0000 carrier board, and I following this steps as reference

My steps:

[On Host]
$cd ${TARGET_BSP}/…/
$tar xpf ${ToT_BSP}/…/ota_tools_R32.6.1_aarch64.tbz2 -C ./
$sudo ./tools/ota_tools/version_upgrade/build_base_recovery_image.sh jetson-xavier-nx-devkit-emmc R32-5 ${BASE_BSP} ${BASE_BSP}/rootfs ${TARGET_BSP}
$sudo ./tools/ota_tools/version_upgrade/l4t_generate_ota_package.sh jetson-xavier-nx-devkit-emmc R32-5

[On Xavier NX with r32.5.1 build]
$ WORKDIR=/home/nvidia/OTA
$ tar xpvf ota_tools_R32.6.1_aarch64.tbz2 $WORKDIR
$ sudo mkdir /ota
$ sudo cp ota_payload_package.tar.gz /ota
$ cd ${WORKDIR}/Linux_for_Tegra/tools/ota_tools/version_upgrade
$ sudo ./nv_ota_start.sh /dev/mmcblk0 /ota/ota_payload_package.tar.gz
$ sudo reboot

after reboot , at the system configuration, I got this error and can not going to next step.

Something I did wrong?

Hi jakelin,

I tried the same steps with yours on Xavier-NX-emmc, but I can’t reproduce your issue.
On error screen, If you press Continue anyway or Try again button, can it continue booting?

Suggest you can prepare clean target/tot/base bsp package and try again.

1 Like

Hi carolyuu,
thanks for your reply,
I press continue and go next screen, the Continue button is disabled.
like this,

and I have trying copy the newnest bsp package from SDK Manager download folder (nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra) (rev.3)
but the error still occured.

hi @carolyuu ,

I found the solution,
I download the L4t package and root file system from
instaed of SDK manager download folder.

now ota update is worked, thanks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.