Ubuntu 20.04 'no signal' after monitor sleep or monitor turned off

last friday (4th of June) my drivers were automatically updated to the current version 460.80 on Ubuntu 20.04. Now if I turn my monitor (SWEDX display) off or it goes to sleep, and I turn it back on I get ‘No Signal’. This was not the case until now.

Only if I unplug the HDMI cable and plug it back in I get back the signal.

I would appreciate any hints or help, because this is driving me nuts. I tried purging all nvidia related stuff, installing 440 (doesnt work reverts to 460), reinstalling current driver, no change.

I attach my bug report, thanks in advance for any help,


nvidia-bug-report.log.gz (380.5 KB)


I have the same exact issue. This started happening around the same time period, and I assume its connected to an update. I’ve tried going to 465, but the issue persists.
If I turn off the monitor (or it turns off itself) there is no signal when I turn it back on. Plugging the HDMI cable in and out resolves the issue but its really annoying.
Running a 2060 Super.

1 Like


I am quite glad, I am not the only one :-). As a temporary solution for this obvious software problem I came up with a HDMI extension, that I unplug instead of ruining the connector at the display.

@frlb: Could you please add your bug report? Maybe someone smarter than me finds something wrong that is present in both our files…

Thank you.

Can you also please attach nvidia bug report and confirm the last working driver version for you.
Can you also confirm last working driver version if possible.

in my case (not 100% sure) the last working was nvidia-driver-450 (450.102.04-0ubuntu0.20.04.1). The one rolled out in Ubuntu 20.04.1 before the actual 460.80, if I am correct.
Though I have a similar machine with 1080ti (also U20.04.1) where 460.80 is working like before. Maybe this bug-report.sh would be useful?


for me this started to happen after a linux update, not sure if it was 20.04.2 , but it was working fine for me on 465 before this update. It might not be an nvidia driver update issue.

@amrits Unfortunately I do not know what was the last working driver. I’ve spent some days now trying to manually downgrade to solve this, but I just end up in a state where either the drivers to not load at all, or I get a mismatch between kernel/user driver. I’ve attached the nvidia bug report, but do note that all records prior to at least June 10 will probably indicate those driver mismatches.

I have had 460.80, 460.84 (current) and 465 all exhibit this behavior.
nvidia-bug-report.log.gz (381.9 KB)

Some more testing:
Using nouveua driver exhibit the same pattern but worse: signal is lost when monitor is turned off, but replugging the cable doesn’t help so hard reboot is required.

Dropping down to kernel version 5.8.0-53 (default is 5.8.0-55) exhibit the same problem. At this point I’m not sure it’s a driver problem, but figuring out what Ubuntu/Linux update broke this is going to be really painful.

I am now running 460.84, the problem persists. At least the embarrassing stutter playing video files (any resolution up to 4K in VLC, Youtube, Kodi, you name it; audio stutter included) is gone.

Alright, finally some progress on this: dropping down to 450 works (450.119.04 to be exact)!
I had to do this by picking the “server” metapackage.

3 weeks ago I posted about my problem. @amrits is there anything happening? Did you look at our bug reports?

Great solution! I had exactly the same problems with a Philips 288E2 4K monitor and a GT 1030 card. The monitor would not wake up from sleep mode. I could not install the 450-server drivers in ubuntu 20.04, but with ubuntu 21.04 it worked and the monitor again wakes up after sleep as it should. There is definitively a regression in the 460 and 465 drivers.

It also seems to depend on the monitor, I have a few 27" 2K monitors from Asus that do not exhibit this problem regardless of driver version. Maybe some 4K monitors have a ‘deeper’ sleep than others …?

I have the same issue on Ubuntu 20.04 and 21.04.
NVidia driver 450.xx works without any problem (the latest one tested is 450.119.03)

If I install 460.x or 465.x the issue manifests and there is no signal after monitors sleeps.
I also tried NVidia beta 470.42.01 - the issue is still present…

After upgrading video driver, using 460 driver my HDMI connected monitor did not wake up on boot on my dual setup. The Displayport connected monitor worked. The HDMI seems to work better when I but it to 2K instead of 4K.
Changing TTY woke it up.
I also installed the 450 server driver. At first it used a azure kernel that freezed my keyboard and mouse. When using the 5.4.0-88-generic it worked again.

Thanks for the solution. I have a Nvidia 1060 card on Linux Mint 20.2


similar issure here with a 1060 5gb and a philips 34SE2 ultrawide 3440x . If I switch from hdmi1 (my desktop with linux and nvidia) to hdmi2 (second device) everything is fine. When I switch back to hdmi 1 the monitor reports “no signal”. Replugging the hdmi cable of the nvidia machine brings the display back to life.

I switched to the 450 Server drivers and it seems to work fine here.

I am now on Ubuntu 21.10 with Nvidia drivers 495.44 and the problem persists. Switching TTY with ctrl-alt-FNx helps most of the time to bring the monitor back on. Is there really no other fix then reverting to driver 450 …?

I disabled “secure Boot” on my computer bios and it worked. It’s recognizing my external BenQ monitor.

450 does help me obtaining these basic monitor functions (off and on).
Other problems with internet connection and gdm3 seem to appear. Hopefully these problems are less serious than they seem.

Thanks for the input!

+1 with a the same problem I think. Lenovo Extreme X1 Gen 2, was on 20.04 LTS when I first hit this problem after upgrading beyond 450, rolling back to 450 fixed the problem. Had been on 21.04, with drivers pinned to 450 via /etc/apt/preferences.d file. Just upgraded to 21.10 which forced me to 470 I think - problem returned (ie - after screen blanks due to screen saver, laptop screen comes back but second screen over HDMI (actually the primary screen) doesn’t come back. xrandr suggested that the HDMI screen was fully operational (had ‘*’ beside the correct mode) - but still black. Unplugging and replugging HDMI cable was the only solution I found - worked very reliably. Have just rolled back to 450-server (since 450 is now a transition package to 460 which transitions to 470) - and things seem fine again.

bug report attached AFTER going back to 450-server.
nvidia-bug-report.log.gz (342.7 KB)

I can’t help wondering how much longer 450 will be available - would be great if this could be fixed sometime given it’s hitting many people and we can’t upgrade because of it.

Same on Ubuntu 18.04.6, with a GeForce GTX 1050.
Tried every other driver available, and only the 450 version (450.156.00) allows me to toggle away to a different input on my monitor, and then toggle back and still have a signal.
In my case, my screen is a TV, with an AV receiver in between (and the receiver does the input toggle between my Ubuntu box and other HDMI inputs). I’ve also recently changed my receiver and went through this driver experiment again and with both old and new, only v.450 work.