UEFI Nvidia vga console complaints

I have gone to great lengths to appease Nvidia Drivers. The following does not produce a console on my hardware

set linux_gfx_mode=text
    export linux_gfx_mode
    menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-f47d27d1-2d39-4f88-8ecc-cc26d7ab51cc' {
            recordfail
            gfxmode $linux_gfx_mode
            insmod gzio
            if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
            insmod part_gpt
            insmod ext2
            set root='hd0,gpt4'
            if [ x$feature_platform_search_hint = xy ]; then
              search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  6999d3cd-e1c1-4938-8930-10fe35a36b34
            else
              search --no-floppy --fs-uuid --set=root 6999d3cd-e1c1-4938-8930-10fe35a36b34
            fi
            linux   /vmlinuz-3.19.0-14-lowlatency root=UUID=f47d27d1-2d39-4f88-8ecc-cc26d7ab51cc ro  text elevator=deadline zcache nomodeset i915.modeset=0 nouveau.modeset=0 video=vesa:off vga=normal init=/lib/systemd/systemd nomdmonddf nom$
            initrd  /initrd.img-3.19.0-14-lowlatency
    }

this still yields the infamous

[    6.615376] NVRM: Your system is not currently configured to drive a VGA console 
    [    6.615379] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver 
    [    6.615381] NVRM: requires the use of a text-mode VGA console. Use of other console 
    [    6.615383] NVRM: drivers including, but not limited to, vesafb, may result in 
    [    6.615384] NVRM: corruption and stability problems, and is not supported.

Thomas Lübking from kde.org telling me its all in my config:

On Freitag, 17. April 2015 01:06:51 CEST, lavacano wrote:

its a EFI/nvidia/VGA bug
No. It’s a grub thing. Grub allocates a framebuffer and you either have to preventi it from doing so or make it release it again.

“it just works”
The behavior is undefined. It works until it does not.

there is literally no combination of vesa/uvesafb/vesa off console=text that works in any case
See the archlinux link. It’s a grub thing.

never not throw that error when using UEFI and Nvidia linux :(
I won’t believe there’s an UEFI that keeps a framebuffer open after its init job is done until I see one ;-P

I yield to hivemind’s superior grub wrangling, I saw another post where the moderator only said “your probably in the clear” Then this is a bug.

FYI:

cat /etc/default/grub | sed '/^\#/d'
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="text elevator=deadline zcache nomodeset i915.modeset=0 nouveau.modeset=0 video=vesa:off vga=normal"
    GRUB_CMDLINE_LINUX="init=/lib/systemd/systemd"
    GRUB_TERMINAL_OUTPUT=console
    GRUB_GFXPAYLOAD_LINUX=text
    GRUB_TERMINAL=console

FYI this might be the cause of corruption bugs starting to arise:

https://bugs.kde.org/show_bug.cgi?id=346024

If you’re booting in native UEFI mode, you will always have efifb loaded. Otherwise there’s no console at all, just a blank screen. But, as the warning clearly says, Nvidia only supports a VGA console. Which consequently means native UEFI is not supported, you need to boot in BIOS compatibility mode.

Yeah, this is clearly something Nvidia will need to work on, considering UEFI is now the norm. But as it is, the warning says there might be corruption, so it’s not surprising that there’s corruption. So you’ll have to boot in BIOS compatibility mode until Nvidia officially supports native UEFI.

I cannot put to words the amount of negative feelings this realization has caused.

I use both efifb and the nvidia binary driver without issues, switching from X to tty works.

I boot using the Linux kernel stub loader though, not grub.

So I installed linux via efistub this is still in dmesg

[    7.825469] NVRM: Your system is not currently configured to drive a VGA console
[    7.825472] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[    7.825474] NVRM: requires the use of a text-mode VGA console. Use of other console
[    7.825476] NVRM: drivers including, but not limited to, vesafb, may result in
[    7.825477] NVRM: corruption and stability problems, and is not supported.

The warning will always be there, because efifb is, no matter which loader is used. vekin is merely saying it works for him. It works for a lot of people without any instability of corruption. On my old BIOS system I used vesafb with the nvidia blob, no problems ever. But that’s by chance, not by design.

The message is a little misleading in UEFI mode. What it means it that the GPU was initialized to a graphical mode using the legacy VGA BIOS, regardless of whether the system was booted in UEFI mode or not. Typically this happens if the Compatibility Support Module (CSM) is enabled in the system BIOS. If you have an option to disable CSM in the SBIOS, please try that.

[    7.945413] NVRM: Your system is not currently configured to drive a VGA console
[    7.945416] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[    7.945418] NVRM: requires the use of a text-mode VGA console. Use of other console
[    7.945420] NVRM: drivers including, but not limited to, vesafb, may result in
[    7.945421] NVRM: corruption and stability problems, and is not supported.

UEFI Stub, CSM Full Disabled

Could it be that I’m using Other OS in secure boot and an unsigned kernel because I am going to try that next :(

FYI: ASUS m5a99fx pro r2.0

What graphics card are you using? If it’s not fairly recent then it might predate the signed GOP driver that’s included in the VBIOS in recent cards.

GTX 760

It’s interesting how recent this thread is, gien how many threads there are about the error message all over the internet for years.

I’m typing this on a white plastic iMac. Whatever typos there are is due to display lag. This hardware is nearly a decade old, UEFI is not exactly new. nVidia, just open source it.

BTW, if anybody could give me an idea how to improve display performance on said iMac with its unsupported GeForce 7300 GT, I’m all ears. Certain programs (Chromium) are unusable due to video lag, others are fine.

AAny word back on this?

Been having issues with KDE sleep corruption forever, I have had Nvidia 660GTX, and now 760GTX, using drivers 304->349 both experienced the same issue with screen corruption after sleep in KDE.
Saw this error a long time ago and assumed it was safe to ignore since you cannot boot EFI without the EFI framebuffer…

Changing my boot setup from EFI Stub kernel to MBR Bios boot with grub and using the /etc/default/grub config as specified by the OP fixed corruption after sleep in KDE and removed the dmesg error for me.

It is save to ignore these messages. Will future version of Nvidia driver handle uefi console?

this seems to be highly system firmware dependent. On my dell I don’t have any problems with UEFI and the nvidia driver, I even get the “standard” text console with the kernel’s builtin simple framebuffer driver. Suspend/resume do work as well, the only “issue” I have is that on resume there’s random garbage on screen for a split second until the kde lock screen appears.

Just wanted to say that I’ve gotten this message to go away when using UEFI on my GA-X79S-UP5-WIFI by:

  1. Selecting the RSTe RAID mode on the motherboard’s storage controller, as it seems to have an UEFI OPROM;
  2. Choosing “Windows 8” as the installed OS in the BIOS settings;
  3. Disabling CSM in the BIOS settings;
  4. Switching the boot mechanism from GRUB to EFISTUB (not actually sure if this was required).

Like someone said before, not all cards support fully UEFI boot. I got Zotac 760 where it will display this message because it cannot boot fully in UEFI mode. However switching to 970 this error message wont show up.

I know that MSI had on their forums a rep where you could ask for a updated BIOS for your card and they would give you the instructions on how to flash and provide you with a BIOS file.

I’m not usually one to necropost old threads, but because it might be helpful to others, disabling CSM removed the message and seems to have fixed my graphics corruption problems. In my UEFI, CSM was automatically enabled in every mode except Normal Boot (Fast Boot, Ultra Fast Boot) and further the setting was hidden from me until I tried normal mode!

I selected normal mode in my ASRock UEFI, and then CSM appeared (showing enabled as the default) to finally give me the option of disabling. It might be helpful if the error message was updated to suggest that CSM might lead to a BIOS mode boot with some firmwares (and subsequent corruption in some cases).

Here’s hoping my necropost wasn’t too ignorant or offensive. Your post was extremely helpful.