Unable to build container for Jetson Nano

I am trying to create an image for my Jetson Nano by building a container from the docker file found at Docker build for L4T Jetpack image. Initially I ran the docker build command myself, but then I realized the makefile is there to do that. Either way the build fails and here is the output

And so you can see that I do in fact have the makefile in the same folder


My questions are:

  1. Will the docker container/image created from this build allow me to write my code using opencv, cuda, etc.?

    I chose this template docker file because it seems like it should. I’m planning to develop in C++ and I just wanted an empty container with all of the necessary dependencies so I can just start coding, then build the container and have it just run on my nano. I have gotten a container to work before, but it was a basic “Hello World” container that wouldn’t support opencv and cuda.

  2. How do I resolve the error I received?

Thank you in advance for your time!

Hi @crose72,

This topic will be best served in the Jetson Nano category. I have moved it over so the support team has visibility.

Tom K


Based on the log, do you try to build the container on an x86 machine?
If yes, could you try it on the Nano to see if it works?

The container only has the OS installed.
To get more libraries, you can try other containers on our NGC website:



So yes I am building these on an x86 machine, but I do so in an emulator environment using qemu, so it would be as if I tried it on the Nano.

So I realized that one reason that I got the above error was because I had forgotten to start the emulator. I then corrected that mistake and tried building the image again and got a new error:

“E: Unable to locate package nvidia-cuda-dev”

Then I did try building it on the nano and received the same error as above:

“E: Unable to locate package nvidia-cuda-dev”

I will note that I changed the tag in the makefile to be r32.7.1 instead of the default r35.1.0, since that’s the version of, I wanna say jetpack or L4T, that is on my Nano.

I’m going to take a look at the page you sent me as well and see if I can get one of those to work.

P.S. Sorry about the late reply. I try to be quicker than this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.