Unable to connect to broker library

I am following the deepstream occupancy analytics blog and trying to run the same in my local. I am getting the below error when i try to run the deepstream-test5-app -c configs/test5_config_file_src_infer_tlt.txt command inside the deepstream docker. When i try to run that with [sink1] type=6 the below error is coming.

[sink1]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=UDPSink 5=nvoverlaysink 6=MsgConvBroker
type=6
msg-conv-config=dstest5_msgconv_sample_config.txt
#(0): PAYLOAD_DEEPSTREAM - Deepstream schema payload
#(1): PAYLOAD_DEEPSTREAM_MINIMAL - Deepstream schema payload minimal
#(256): PAYLOAD_RESERVED - Reserved type
#(257): PAYLOAD_CUSTOM - Custom schema payload
msg-conv-payload-type=0
msg-broker-proto-lib=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_kafka_proto.so
#Provide your msg-broker-conn-str here
msg-broker-conn-str=localhost;9092;quickstart-events
#topic=
#Optional:
#msg-broker-config=…/…/deepstream-test4/cfg_kafka.txt

root@2b050d2e90e6:/opt/nvidia/deepstream/deepstream-5.0/streams/sources/apps/sample_apps/deepstream-test5# deepstream-test5-app -c configs/test5_config_file_src_infer_tlt.txt

(deepstream-test5-app:4119): GLib-CRITICAL **: 10:45:22.352: g_strchug: assertion ‘string != NULL’ failed

(deepstream-test5-app:4119): GLib-CRITICAL **: 10:45:22.352: g_strchomp: assertion ‘string != NULL’ failed
Warning: ‘input-dims’ parameter has been deprecated. Use ‘infer-dims’ instead.
** ERROR: main:1451: Failed to set pipeline to PAUSED
Quitting
ERROR from sink_sub_bin_sink1: Could not configure supporting library.
Debug info: gstnvmsgbroker.c(388): legacy_gst_nvmsgbroker_start (): /GstPipeline:pipeline/GstBin:sink_sub_bin1/GstNvMsgBroker:sink_sub_bin_sink1:
unable to connect to broker library
ERROR from sink_sub_bin_sink1: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Debug info: gstbasesink.c(5265): gst_base_sink_change_state (): /GstPipeline:pipeline/GstBin:sink_sub_bin1/GstNvMsgBroker:sink_sub_bin_sink1:
Failed to start
App run failed

Here i am attaching the config file.
test5_config_file_src_infer_tlt.txt (6.6 KB)

change to

msg-broker-conn-str=localhost;9092
topic=quickstart-events