Unable to install target SDK Components on Jetson TX2

I’m trying to setup my Jetson TX2 and install SDK components on it, but the installation fails with the following error:

Cannot connect to the device via SSH. Validate that SSH service is running on the device.

Based on the log, it seems like flashing was successful, but installation of SDK components is where the problem is. I did go through the forum about some possible fixes and debugging, but so far I’ve been unlucky to get it fixed.
Additionally, not sure if it’s relevant, but a notification keeps popping up on my host device that says:

Connection failed - Activation of network connection failed (even though I have an active WiFi connection)

I’m running Ubuntu 18.04 on my computer, and if it helps, I’ve attached an excerpt of the log as well for reference. Any help with this issue would be appreciated, thanks!

log (2.8 KB)

Did you complete the first boot account setup after flash completed? Without that there is no possibility that ssh can succeed since ssh requires a login account. Note that if no account was set up it won’t matter if networking via ethernet, WiFi, or USB virtual ethernet is used…login won’t be possible.

If you can ping the network address from the host PC, then likely flash completed 100% and the unit rebooted and is waiting for account setup.

Since I’m new to this, I’m not entirely sure about what you mean by first boot account setup. But I’m assuming that it means the creation of an account using just the Jetson standalone (when it’s directly powered). If that’s the case, I created an account then (the steps were similar to when I first set up Ubuntu on my computer)

If you can log in locally to the Jetson via mouse/keyboard, or via serial console, then first account setup is complete and you are ready for adding components.

If you can ping the IP address of the Jetson, and you have named that address in SDKM for contact, then it should work. The “acid test” is to see if you can manually ssh to the Jetson from the host PC and log in using the name/pass you set up. If manual ssh to the Jetson from the PC works, then any failure to install components would be a different issue versus account setup.

Going step by step, I tried logging in locally to the Jetson via a keyboard/mouse connected to a display, and was able to do so.
Pinging the IP address of the Jetson (192.168.55.1) also yields some output. although I’m not sure what you mean by naming the address in SDKM, because I haven’t done that).

I tried sshing to the Jetson using ssh nvidia@192.168.55.1 (I named my device nvidia), but that yields an error:

ssh: connect to host 192.168.55.1 port 22: Connection refused

update: I was wrong, when I flashed the Jetson, it looks the account I created with Jetson does not exist any longer (i.e gets deleted in layman terms. I verified it by connecting the Jetson to my display and I get the following screen (attached image))


Summarizing what I’ve done once again (using this link as reference - https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html)
-step 3, point 5, I choose manual setup since I’m flashing Jetson for the first time
-step 3, point 6, I enter a username and password, and when I click install, that’s when I run into the following error: Cannot connect to the device via SSH. Validate that SSH service is running on the device)

Hi mv24,

After flashing, Jetson TX2 will need your manual input to set up user name and password, as well as other configurations. If this step is not done, you will not be able to ssh connect to it.
Can you please open a terminal window on your host, and ssh connect to Jetson TX2 in this terminal to see if there is any issue?

Hi @EdwardZhou,

If I’m understanding it right, do you mean performing the flash (by choosing Manual Setup when prompted in SDK Manager), disconnect the Jetson from the host so that I create an account on it locally (i.e using it standalone)? Following which I ought to go back to the SDK Manager, and now instead choose Automatic Setup so that the components can be installed on the Jetson?

When I tried

ssh nvidia@192.168.55.1

right after the process failed during manual setup on the host, I got the following error - ssh: connect to host 192.168.55.1 port 22: Connection refused

The name of the device is unrelated to the login name. I suspect you mean you created account “nvidia”, and if so, then your procedure is correct.

If you can ping 192.168.55.1 (and it seems you can) while logged in to the host PC, then you know the USB virtual ethernet is set up correctly as well. This would imply any ssh issue is not due to networking.

It may take a minute or so for ssh login to be available, but for the most part, if ping worked, then it implies ssh should also work (the two become available almost simultaneously).

A refused connection tends to imply that either the port is firewalled, or else the ssh daemon is not running on the Jetson. By default ssh daemon is enabled on the Jetson, and by default, the Jetson does not have firewall set to deny anything.

If you were to log in locally to your Jetson with keyboard and mouse, then an alias for “the computer you are currently logged in to” is “localhost”. While logged in directly to your Jetson, can you do this? If so, then ssh is working, and if not, then we have new debug information:
ssh localhost
(then login to “nvidia”)

NOTE: SDKM by default uses address 192.168.55.1 for ssh. You’ll see this showing up on the SDKM GUI when at the correct step. You could change this to some other address, e.g., to a known correct wired ethernet setup (but you don’t have to…the 192.168.55.1 should work since ping works).

I waited for quite some time, but the ssh error was still there.

So to rephrase my issue, I can create an account and login to the Jetson only when it’s working standalone i.e not connected to any host. Whenever I’m using SDK manager (when the Jetson is connected to my host linux machine), I get the ssh error indicated, and just to get an idea of what I’m running into, I connect my display to the Jetson and I get what is shown in the image below (it does not proceed beyond this point - so I do NOT get to the stage of account creation/system configuration wizard of Jetson):

Hi mv24,

The screenshot shows that the OEM configuration is not finished yet. Ssh server is only enabled after OEM configuration is finished.

After flashing the board, on the very first boot,

  • If board is connected with HDMI
    • User must configure the oem on HDMI display.
    • User cannot configure the oem with “minicom -D /dev/ttyACM0”, there is no output with minicom
  • If board is not connected with HDMI
    • User must configure the oem with minicom, e.g., minicom -D /dev/ttyACM0.

After OEM configuration done, board can be started successfully and connected with ssh.

A note in addition to what @EdwardZhou mentions: At the point of the screenshot flash is completed and the system has rebooted to normal operation. No account exists yet, and thus you cannot ssh in…you need the account. After that you or JetPack/SDKM can install extra packages since package installation occurs when fully booted and not when in recovery mode.

2 Likes