Unable to launch GUI on RHEL 7.5/elrepo-ml 4.17/MSI GS63VR/GTX1060 rig

Hello,

I have been trying for a few months now to get a GUI setup on my laptop. It is a MSI GS63VR. I initially tried using stock RHEL 7.5/3.10-862 kernel and used the Elrepo kmod-nvidia/bumblebee/primus setup but I never got this to work I always ended up with a ‘hung’ terminal.

After several iterations of installs (of both the OS and kmod-nvidia) the furthest I could get was a single failure in Xorg.log - "“Failed to open DRM device for (null): -2"”

Having browsed quite a few articles on google, I was getting the sense that relatively new MSI laptops do not play well with ‘older’ kernels. I therefore deceided to install a relatively recent kernel and try once more. I went with Elrepo-ml 4.17 kernel. I followed a definite list of steps (which I’ll outline below) but I could not launch into GNOME/KDE. The last error I get in my Xorg.log is “Failed to initialize GLX extension (Compatible NVIDIA X driver not found)”. In the Xorg.log, I can see that nouveau is loaded even though i blacklisted it. I’m guessing the ‘X’ packages have nouveau as a dependency and so are trying to load it? I didn’t think that nouveu would be loaded as i also have “install nouveau /bin/false” in my blacklist file.

I have enclosed the output from running “startx – -logverbose 6”. I have also attached nvidia-bug-report.log.gz.

Brief outline of my installation steps:

  1. Install base RHEL7.5 linux minimal
  2. Update to latest kernel
  3. Reboot
  4. Install EPEl and elRepo kernels
  5. Reboot
  6. Install elrepo-kernel-ml
  7. Reboot
  8. Install kernel-ml-devel, gcc, dkms
  9. blackist and remove nouveau
  10. Rebuild grub (EFI based) and initramfs
  11. reboot
  12. Install GUI packages
  13. Reboot
  14. Install NVIDIA-Linux-x86_64-390.77
  15. Reboot.
  16. startx

I initially tried with NVIDIA-Linux-x86_64-396.51 but I got the same error.

Any help or pointers would be much appreciated. After months of getting nowhere, I am on the verge of just using the laptop as a windows machine!

Thanks in advance,

John
nvidia-bug-report.log.gz (84.6 KB)
Xorg.0.log (32.6 KB)

Another vote of thanks to yalniz!!! https://devtalk.nvidia.com/default/topic/957814/linux/prime-and-prime-synchronization/22

After several months of battling, I finally can get a GUI screen on my laptop!

Reviewing that post and looking a little bit closer at my Xorg.log file, it became clear that none of my install steps had resulted in an xorg.conf file being created!!

I therefore used the contents of yalniz’s post to create my xorg.conf file. I also added the option to my grub command line:

quiet nvidia-drm.modeset=1 acpi_osi=

I rebooted, and lo and behold, I got a GUI!!!