Unable to run jetson_clocks on Jetson AGX Xavier


When I am trying to run jetson_clocks on my jetson agx xavier , I am getting error as unknown gpu type. Please check below screenshot:

I dont know what happened suddenly , previously I was able to run now I am getting this error. Please let me know how can i resolve this…

I think you could flash the device again and try running jetson_clocks again.

I’ll also suggest flashing. Btw, have you ever installed a GPU driver separately? The GPU driver must come from the JetPack/SDK Manager software (the ones you find separately are for discrete GPUs, which run on PCI, but Jetsons have an integrated GPU).

No , I have not installed gpu driver, I just tried to install jetson-stats latest version and after that this happened.

Is there any way to resolve this without re-flashing??

I don’t know what jetson-stats does for software install. If you installed it via a package, try removing the package and testing again.

Also, assuming you’ve flashed this in the past, and assuming you still have the flash content, then compare the sha1sum from the host PC’s “Linux_for_Tegra/rootfs/usr/bin/jetson_clocks” to the Jetson’s “/usr/bin/jetson_clocks”; are they the same file? If not, then try to copy the jetson_clocks file from the PC to an alternate location on the Jetson, e.g., copy to “/usr/local/bin”, and then see if “sudo /usr/local/bin/jetson_clocks” behaves the same way.

I tried uninstalling the jetson_stats package but still getting the same error with jetson_clocks.

For comparing , I don’t know how can i take sha1sum for this files . Can you please describe that in short or share any reference link for that??

To take the sha1sum checksum just name the file you are checking. Example:
sha1sum /usr/bin/jetson_clocks
(adjust for the path depending on whether it is in the host PC flash content versus on the actual Jetson)

If you don’t have “sha1sum”, then something is wrong since it is part of coreutils. If two files have the same checksum, then they are binary matches.


I tried checking sha1sum for jetson_clocks but it is same as the jetson_clocks on host pc.
Another thing I found some other errors while running sudo nvpmodel -q on my board. Check below:

I think there is some issue with the gpu. Let me know if you have any resolution for this??

Each failing operation is interacting with files in “/sys”. Those files in turn are not real files, but are instead drivers “pretending” to be files as a means of talking to the outside world. So it is possible the GPU has failed, but there are other possibilities. A list is:

  • GPU failed.
  • Driver is wrong.
  • Driver is right, but failed to load due to some other condition, e.g., device tree is wrong.

Can we verify if this is a dev kit, versus a third party carrier board? The flash software on NVIDIA’s web pages is for the dev kit. Sometimes third party carrier boards are exact matches (electrically) to the dev kit’s carrier board, but often they differ and need a custom device tree. In this latter case the manufacturer provides their own board support package (which is usually the same flash software, but with a modified device tree, or else instructions on adding their customizations to the NVIDIA software. Thus when I ask if it is a dev kit what I’m really asking is if it is using the right device tree.

Also, have you ever flashed before? Reflash is likely the next step since a failed GPU (hardware) is rare. More often such things are fixed by flashing with the correct software (meaning device tree plus driver combination for the specific carrier board). If not, what do you see from:
head -n 1 /etc/nv_tegra_release
(to identify the current version of installed software)

Issue Resolved after reflashing.

Thank you all for your support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.