Unable to see my robot in issac sim after importing urdf

I have tried to import a robot using a urdf file, the robot shows up on the stage but does not show up on the viewport. I have tried using .dae, and .obj file formats along with .stl. The result is same. The robot is not visible on viewport. I am able to view it on gazebo.

Hi @amoghv1

Could you please share the .urdf description (with meshes)?

Hi tony,
Sure i will share them
here is the drive link.

Hi @amoghv1

Make sure the parent folder has the same name (wheelchair_camera) as the one defined in the .urdf file.
Otherwise, you will get the following error:

2022-11-17 21:43:21 [1,047,282ms] [Warning] [omni.isaac.urdf] Path: package://wheelchair_camera/meshes/base_link.obj not found
2022-11-17 21:43:21 [1,047,282ms] [Warning] [omni.isaac.urdf] Failed to resolve mesh 'package://wheelchair_camera/meshes/base_link.obj'

Thank you. I am able to see it now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.