Unable to start up development kit


I’m working with a Jetson Xavier NX Development Kit but I’ve encountered some problems.

By mistakenly upgraded the graphics driver to a version higher than the module seemed to be able to support (version 525. something), I am not able to get into ubuntu GUI as usual. The screen I connected is simply flashing without showing any character or interface.

I am not able to get into tty mode by pressing ctrl + alt + Fn, but it jumps back into the GUI start up process after showing lines that ask me to type in login information for several seconds.

I tried to short circuit it to get into recovery mode, yet it did not start up at all.

So what should be the next step?

Hi @liyiru_001,

One idea is to try and see if that you can connect to the board using SSH to see if the issue is only a GUI one, if you know the IP it has in the network, or if you have it connected through the USB to the host pc you can connect to the IP

On other notes, when attempting to put your board in recovery mode, are you trying to flash it again?
Does it show in the host PC after connecting the USB by running the command:


In order to succesfully put the board on recovery mode, you can check this guide for flashing we have created, on Step 2: Set Board in Recovery Mode : NVIDIA Jetson Xavier - Flashing Board - RidgeRun Developer Connection

Maybe you can even walk through it in order to reflash the board if that can help you recover it, please note that is for JetPack 5.0.2.

If you have any question or comment let me know,
Roberto Gutierrez,
Embedded SW Engineer at RidgeRun
Contact us: support@ridgerun.com
Developers wiki: https://developer.ridgerun.com/

Hi Roberto,

Thanks for your response. I don’t think I have configured ssh on the board before, nor I know the IP it has. Does the host PC have to have a Linux system? I tried to use a PC with WSL as host but got nothing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.