Jetson Xavier AGX won't boot into GUI

Nvidia Jetson Xavier AGX Developer Kit, Running Ubuntu 18.04.4, tegra 4.9.140

I have been using DetectNet for some time, using it with a Camera to perform object recognition and display the image with bounding boxes on a GUI. However, I booted it up today and it booted into a command-line mode (from reading other posts it could be called ‘text-mode’) and I can’t find a way to restart the GUI.
One thing to note is when I booted it up it asked me if I wanted to run ‘unminimize’ because some unnecessary packages had been removed, so I ran that anyway incase but it made no difference. Other things I have tried (rebooting in between as required):

sudo systemctl set-default

No change after reboot

sudo systemctl start gdm3.service

Nothing happened

sudo service gdm3 start

Nothing Happened
(using ctrl+alt +f2 or ctrl+alt +f1 only opened other text consoles)

When I try and run my GUI app from the command line, I get the following error:
[OpenGL] failed to open X11 server connection
[OpenGL] failed to create X11 window

How can I re-enable or reinstall the GUI (which I think was Gnome?), preferably without having to reflash or reinstall the whole OS again?

Thanks in advance.


Could you try to install " ubuntu-desktop" through apt-get?

Unfortunately I may have made things worse…

I saw a post on another linux forum that suggested i should reinstall gnome (sudo apt-get install gnome) and then perform

sudo service gdm3 start

However I am now stuck in an infinite boot loop. I cant use ctrl-alt-F1 (or F2,) to get to any type of command line, it just displays part of the boot sequence and then restarts.

The only error message I can see is:

[FAILED] Failed to start Load Kernal Modules

Any ideas on how I can at least get out of this so I can recover the files on there?

When such things happen, it’s probably hard to recover.

You could dump the serial console log from UART too see why the device keeps rebooting. But since you cannot interact with the device, it may not get fixed.

OK so strangely I connected to it using miniterm on another linux machine via its micro-usb port and it booted up first time?! I havn’t sent any commands, all that’s changed was it was booted with that USB plugged in so I could check the serial and it booted up.

I have now copied across all the thing I needed to (a lesson in backing things up as usual) so will now try:

sudo apt-get install ubuntu-desktop

I also saw on another forum post that:

dpkg --configure -a

Had some success for other users, so if it doesn’t boot up again after I power-cycle it I will try that too.

Will post results once I have tried these things in case other users experience similar issues.

I spoke too soon, whatever happened was a fluke and a miracle because I can’t get it to boot again. This is the serial log from the USB port (attached as txt file).

Now stuck back in the boot loop.

xavier_serial_boot_log_failre.txt (30.3 KB)

Unfortunately, there is kernel panic and cause your device to reboot.

For such case, the fastest way to resolve is re-flash your board.

Is it possible to just re-install or repair the kernel? If I leave it for a while it eventually boots up, sometimes after 5 attempts but sometimes more, either way I can get access to a command-line if I leave it long enough


If the A/B redundancy is enabled, then attempt to reboot failure for 7 times could boot into backup partition.

However, according to your description so far, I don’t think you really know what you’ve done to your device.

There are some kernel modules in rootfs which has no backup mechanism.

Your error is from gpu driver which is in rootfs, so it is possible to still get failure even after system boots into backup partition.

Thus, I think the fastest way is re-flash

Incidentally, a kernel panic is not usually caused by the kernel code changing or having a bug which can be fixed by using a different kernel. The most likely cause of such a panic would be the arguments or data passed to the kernel during a call to a driver. If you removed the driver or overwrote it, then obviously this will go badly. On the other hand, if something in the arguments passed to the kernel during init are invalid, then replacing the kernel will have no effect since the guilty code is really the code which passes the arguments and not the kernel itself.

1 Like

Thank you @WayneWWW and @linuxdev , I don’t know what happened to it between being shutdown and turned on the next morning but I did just end up reflashing it, bit of a pain to reinstall everything (re-installing opencv is proving to be particularly challenging) but just as you suggested it was the quickest solution.

Thank you for your help.