Unable to tweak `nvidia-settings` on remote server

I am using Ubuntu 20.04.6 LTS on a shared remote desktop with NVIDIA T400 4GB GPU. I am accessing this desktop over a virtual desktop solution.
I have tried different versions of the graphics driver but currently using 535.104.05 installed from ubuntu apt repo.

I am running a simulation software developed using the Unity game engine and experiencing extremely poor performance (< 10 fps). In order to debug the issue, I have tried a few different things and my suspicion is that the unity application is running with an integrated Intel GPU, as opposed to the nvidia GPU, which I want it to run on.

I checked the performance of GPU using some benchmarking tools and can get 3000+ fps. But if I am not wrong, that is probably because the gnome-shell, and my virtual desktop UI does indeed run on the Nvidia GPU.

As next steps, I was hoping to try two things:

  1. Force the OS to always use NVIDIA gpu
  2. Force the unity application to use NVIDIA GPU

For#1, I wanted to see if I can play around with the nvidia-settings. But I get the following error, when I try to launch it.

sudo nvidia-settings

** (nvidia-settings:152303): WARNING **: 12:22:34.615: Unable to connect to dbus: The connection is closed

ERROR: Unable to load info from any available system

(nvidia-settings:152303): GLib-GObject-CRITICAL **: 12:22:34.684: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 12:22:34.685: PRIME: No offloading required. Abort
** Message: 12:22:34.685: PRIME: is it supported? no

(nvidia-settings:152303): GLib-GIO-CRITICAL **: 12:22:34.704: g_dbus_connection_register_object: assertion ‘G_IS_DBUS_CONNECTION (connection)’ failed

(nvidia-settings:152303): GLib-GIO-CRITICAL **: 12:22:34.704: g_dbus_connection_register_object: assertion ‘G_IS_DBUS_CONNECTION (connection)’ failed

(nvidia-settings:152303): GLib-GIO-CRITICAL **: 12:22:34.704: g_dbus_connection_get_unique_name: assertion ‘G_IS_DBUS_CONNECTION (connection)’ failed

I went down the rabithole on this issue as well, but have hit a wall. How can I get the nvidia-settings to show up?

I am attaching the bug report.
nvidia-bug-report.log (15.4 MB)