Unable to upgrade SX1012's to newer OS Version

Hi All,

I’m currently running MLNX-OS 3.6.2002 on 2 x SX1012 which are in MLAG config. I’ve tried updating to 3.6.4112 on the standby node but it just failed. It came back up running the 3.6.2002 image. I tried selecting the image 2 again and reboot and same thing. I then tried upgrading to an older version 3.6.4006 and same thing. i’ve also rebooted the master so it became standby and then tried upgrading that node to 3.6.4006 and it also fails.

I can’t see anything in the logs so I’m not sure what is going on. I’ve checked the RN’s for each version I’ve tried upgrading too and both support upgrading from 3.6.2002.

It appears that I’m unable to upgrade either of the switches. Can anyone shed some light on this or let me know an appropriate course of action to take to be able to upgrade?

Any help would be greatly appreciated.

I am upgrading using WebGUI.

Cheers,

Ben

Hi Ben,

Try to run the command “image boot next” from config mode via the cli.

Below is the full upgrade steps via cli:

  1. configure terminal
  2. show images
  3. image delete
  4. image fetch scp://username:password@/<image_name>
  5. image install <image_name>
  6. image boot next
  7. show images
  8. configuration write
  9. reload

Cheers,

Marlon

Hi Marlon,

It’s taken a while for me to get back to this issue.

I have tried the steps you have suggested and it still fails.

I guess I’ll go and open a support ticket.

Cheers,

Ben

Hi Marlon,

Thought I’d update this thread with the answer which was kindly supplied by a Mellanox tech support person.

We had "dcb application-priority ethertype xxxxxx" configured which was causing the issue. We removed, restarted and then successfully were able to update.

Cheers,

Ben