Unity desktop not loading in Jetson TK1

I have received the Jetson TK1 board today.

As I powered it up, I did not see a GUI loading. I logged in (text based) using the username and password, and peformed the following:

sudo apt-get update
sudo apt-get upgrade
sudo shutdown -r now

The unity desktop still did not load.

I tried booting it manually by
sudo unity
and got the message
No display variable set
and later by
sudo service lightdm start

but no success there…

Any suggestions

I didn’t see a GUI either when I received mine.
After installing L4T R19.2 everything worked as expected.


OK, I flashed the device

It seems to boot, however the boot gets stuck with a message:
Can’t set audio to 44100 at 13850400 pix_clock
It has something to do with the HDMI and I’m not sure why I’m even getting this.

Did you eventually fix the issue?
I am too having problems with my HDMI connection.
I’ll try to flash 21.2 to it, and see if it will work.

There is currently an issue with apt-get update overwriting a critical file.

sudo apt-mark hold xserver-xorg-core
beforehand to protect it.

Did you installed the gpu drivers inside the /home/ubuntu/NVIDIA-INSTALLER folder?

In my case, flashing the 21.2 version fixed the issue. No need for anything else.