USB doesn't work and dts file update compiling error happend

We designed a carrier board, for some reasons we removed the power monitoring circuits. Later, we connected a TX2 module to debug the functions, the USB and PCIE (M.2, M key) interface didn’t work.
Then I tried to follow some posts to modify the dts file “tegra186-quill-p3310-1000-a00-00-base.dts”:
pinctrl@3520000 {
vbus-0-supply = <&vdd_usb0_5v>;
vbus-1-supply = <&vdd_usb1_5v>;
vbus-2-supply = <&battery_reg>;
vbus-3-supply = <&battery_reg>;
vddio-hsic-supply = <&battery_reg>;
avdd_usb-supply = <&spmic_sd3>;
vclamp_usb-supply = <&spmic_sd2>;
avdd_pll_erefeut-supply = <&spmic_sd2>;
However, I got some errors during the later compiling, such as “Reference to non-existent node or label ‘vdd_usb0_5v’”, but i did find the node in the dtf file. What’s the possible reason?
Node Definition

When i used TX2 4GB, the usb interface is functional w/o modifying the dts file, doesn’t TX2 4GB monitor the power? In the later test, it seemed the USB connection was not reliable, some USB disk can be used w/o problem, and some others couldn’t even be detected.

Appreciate for your advice.

The dts file of TX2 4GB is
Please refer to adpatation guide and modify per your design:

Some examples for your reference:

Hi DaneLLL,
Thanks for the reference.
We tested with both TX2 and TX2 4G, the TX2 4G worked except for the issue some USB disk were not detected(is signal integrity issue?), so we didn’t modify the dts file “tegra186-quill-p3489-1000-a00-plugin-manager.dtsi”.
Now the problem is we failed to compile the modified TX2 dts file, what could be the reason?

Some nodes are specific to r28. You probably refer to the nodes. On r32, please check the part of dts in


Hi DaneLLL,
Since we used TX2 4G, based on the suggestion in some posts, i downloaded the source file from NVIDIA website, and made the change “vbus-2-supply = <&battery_reg>” in the dts file “tegra186-quill-power-tree-p3489-1000-a00-00.dtsi”, then did the kernel compiling, and at last copied the generated dtb file "tegra186-quill-p3489-0888-a00-00-base.dtb"to my dtb folder and flashed to the TX2 4GB, but the USB interface still doesn’t work. It’s getting more tricky now.
Do you have a quick instruction on how to compile the device tree only? it takes much time to compile the kernel each time.
My dtsi file enclosed.tegra186-quill-power-tree-p3489-1000-a00-00.dtsi.log (8.8 KB)

Issues was fixed. Thanks.

1 Like