USB_FS memory allocation

I follwed the solution provided in the below topic.

By re-flashing the AGX xavier with below command without changing any original jepack files

sudo ./ -k kernel -C “usbcore.usbfs_memory_mb=1000” -k kernel-dtb jetson-xavier mmcblk0p1

Reflashing done successsfully but when i turn on and check the usbfs_memory_mb,its still shows default 16MB.

Please re-flash the system( without -C usbcore.usbfs_memory_mb=1000 ) and only apply this:
change usbcore.usbfs_memory_mb [SOLVED] - #6 by sidneib

Ideally the setting in extlinux.conf shall be applied. Please add the line and reboot the system for a try.

I have tried the mentioned solution as well.But still it is showing default value.

Does it work if you modify the value directly?

# echo 256 > /sys/module/usbcore/parameters/usbfs_memory_mb


its working, but everytime i reboot or power cycle jetson , i need to set it manually, i m trying to flash permanently, please help in approach, thanks

A possible solution is to run a script at startup. Please refer to Jetson Nano FAQ

Q: How to autorun an app or commands at startup?

A bit strange that it doesn’t work by modifying extlinux.conf. This would need other users to share experience.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.