USB mouse and keyborad not working

I flashed Jetson AGX from SDK manager after that no mouse or keyboard is working,
I tried to check the power is USB port, There was power in USB port before Boot logo but after that there was no power in the USB port.
is there a way to fix it ?

You can remove the quiet inside rootfs/boot/extlinux/extlinux.conf, reflash your board again and share the uart log.

Hi @WayneWWW ,
I took the uart log as you said.
I have attached the file here kindly check out.
AGX_Uart_log_2_2_2022.log (95.9 KB)


Just want to double confirm, is this a custom board or this is a NVIDIA developer kit?

Hi @WayneWWW ,
Its the NVIDIA’s developer kit.

Is this your first time using this kit or this board was working before?

Do you have other developer kit on your side?

Hi @WayneWWW ,
I have been working on this kit for the past 7 months and had no issues.
I also had another Xavier in which I am facing the same issue from today morning.

hmmm… I am not sure what you are doing. Does your work frequently change something through i2c bus?

Hi @WayneWWW ,
I am developing custom camera driver with ov5693 driver as reference.
Yes I do frequently work on I2C bus since I program my image sensor using I2C.

Does the log you just shared integrate the driver you are using here or it is a pure one from jetpack?

Hi @WayneWWW ,
it’s not pure from the Jetpack, Its from the Driver I integrated.
I also tried flashing using the SDK manager and still faced the same issue.

Please flash pure BSP from jetpack. The only modification allowed is remove the “quiet” inside your extlinux.conf.

Please share the log from both two kits you are using.

Hi @WayneWWW ,
Please have a look at the logs of both Xavier.
AGX_003_SDK.txt (16 KB)
AGX_004_SDK.txt (42.2 KB)

You didn’t remove the “quiet” so the log is incomplete. The first one is even not boot into kernel.

Please try to dump full log.

Hi @WayneWWW ,
I tried to reboot it several times and got that much of log only in the 1st one and the log stopped but AGX boot was completed properly

Could you just take a video of what you see on the console tool after you power on the board for the first board?

I don’t know if you understand that if the board just stopped print log as the first board, then it is not “usb issue”, your board is not booting up at all and you shall not see anything on the monitor.

Hi @WayneWWW ,
Sorry My mistake I will try to flash again and take log because by mistake I overwritten the log.
But I am sure the 1st one boots completely because it ends up in system configuration page.

Hi @WayneWWW ,
I got the uart logs for both the Xavier.
Kindly have a look at it.
AGX_003_SDK.txt (114.5 KB)
AGX_004_SDK.txt (128.2 KB)


I am not sure what you’ve done in your camera driver. The result is both of the type C usb PD controller firmware is being erased by you.

This kind of log keeps spewing in your log file.

[ 41.330571] Could not get extcon-dev /xudc@3550000:vbus(0)
[ 41.356053] Could not get extcon-dev /host1x/nvdisplay@15220000:typec1(1)
[ 41.357586] tegra-xusb 3610000.xhci: USB2 port 0 has OTG_CAP
[ 41.357589] tegra-xusb 3610000.xhci: USB3 port 2 has OTG_CAP
[ 41.361102] Could not get extcon-dev /xhci@3610000:id(0)

And this is the cause of these usb error.

[ 14.440650] tegra-i2c c240000.i2c: pio timed out addr: 0x8 tlen:28 rlen:24
[ 14.443336] tegra-i2c c240000.i2c: — register dump for debugging ----
[ 14.445843] tegra-i2c c240000.i2c: I2C_CNFG - 0x22c00
[ 14.448231] tegra-i2c c240000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[ 14.450633] tegra-i2c c240000.i2c: I2C_FIFO_CONTROL - 0x0
[ 14.453050] tegra-i2c c240000.i2c: I2C_FIFO_STATUS - 0x800080
[ 14.455372] tegra-i2c c240000.i2c: I2C_MST_FIFO_CONTROL - 0x70000
[ 14.457763] tegra-i2c c240000.i2c: I2C_MST_FIFO_STATUS - 0x7c0000
[ 14.460038] tegra-i2c c240000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
[ 14.462303] tegra-i2c c240000.i2c: I2C_INT_MASK - 0x7d
[ 14.464616] tegra-i2c c240000.i2c: I2C_INT_STATUS - 0x2
[ 14.466922] tegra-i2c c240000.i2c: i2c transfer timed out addr: 0x8
[ 14.469261] ucsi_ccg 1-0008: read version failed
[ 14.472287] ucsi_ccg 1-0008: get_fw_info fail, err=-110
[ 14.474941] ucsi_ccg: probe of 1-0008 failed with error -110